Using CSGO props in GMOD, wont showup ingame.

Title explains most of it. My map is a port from CS:GO so I cant make them all prop_dynamic_overide. I tried using the hl2ep2 hammer, hl2ep1 hammer, hl2dm hammer, and hl2 hammer but they all crash when I try to load the map. I also just tried using the vbsp from hl2ep2, hl2ep1, hl2dm, and hl2 but I still got the same error, “Cant load studio model”

From my experience, some models don’t quite work in between games. While the vast majority will work just fine in every Source game, there are some exceptions (Portal 1s’ GLaDos model, for example, causes Portal 2 to crash on map load). Try using the Cordon tool to find which models are causing the crash, then replace them with HL2/Gmod models that work in that place.

EDIT: Another good example is that some of Portal 2s’ models will crash Gmod when the models are loaded. Since CS:GO, like Portal 2, also uses a newer engine branch then Gmod does, it wouldn’t surprise me if several of its’ props were broken in Gmod.

Its not that the props crash GMOD hammer, it crashes the other forums of hammer. And I think valve for csgo would start with EP2 for the engine because it was the most recent at the time, so EP2 hammer would probably work. (props showing up in compile, not crash)

EP2 hammer won’t work with new CS:GO props, it’s also not the engine base. CS:GO inherits from the Portal 2 base engine.

I have been using Crowbar to decompile them and the recompile them for GMod, it works most of the times, sometimes you need to edit a few stuff here and there.

Oh, well it was just a kind of theory. Would you know a fix though?

[editline]15th November 2016[/editline]

Why would decompiling and then compiling fix props not showing up? Its probably an engine thing (props not showing up)

I recently extracted a few models from the CSGO .vpk for GMod and from what I remember it was missing files ending in .dx80.vtx | .sw.vtx | .vdd
De-compiling the model and then re-compiling for GMod gives you the missing files.

Oh. Ok, I’ll try to get those files, thanks!

[editline]15th November 2016[/editline]

Welp, it appears as though I already have .dx80.vtx .sw.vtx and .vdd files for every prop.
Maybe if I select GMod for the BSP format and VMF format it will work.
Also I DID click “Extract Embedded Files”

[editline]15th November 2016[/editline]

Select gmod for the bsp and vmf format didnt work, trying to use only GMod on the bsp format and keep VMF on csgo

[editline]15th November 2016[/editline]

Jimakis98, can you give me a link to your steam profile? We can talk faster threw steam, if you want.

If your problem still isn’t solved, come talk to me.

Still not solved