"Validating Steam Files"...forever?

Starting yesterday, Gmod for some reason refuses to start up any more. Steam gave me a “Validating Steam Files” popup and after that is complete it appears Gmod does not automatically load as expected. I recently reinstalled Gmod about two-three weeks ago.

I thought it was a small glitch with Steam so I just restarted Steam but that didn’t work. Afterwards I assumed I just needed to wait a little longer for Gmod to start since it always took a while to load up anyway. No dice.

I’m just curious if this is a common problem or not and if it can be resolved without simply reinstalling Gmod (something I fear I may need to do now :).

*Just to be clear, this is occurs only for Gmod. No other Steam game goes through this!

Any help appreciated!

I had this,fixed it by restarting my computer.

picture/video plz we cant actualy help you when we dont know what is hapening

This is the solution, because another guy just had this

It seems to have worked. Thank you for the help!