Vehicle spawning wrong

I’m trying to make a camaro driveable for my server. Anyways when its spawned, it spawns with the lower half in the ground and when I get in, it crashes garrysmod. The autorun code is below.

edit: ok ive gotten it to not crash but i cant drive it and it breaks my physgun when i try using it to move the camaro. also the driver’s seat is in the middle of the car facing backwards


--Shepard
resource.AddFile( "materials/models/peterboi/camaro/car00.vmt" );
resource.AddFile( "materials/models/peterboi/camaro/car00.vtf" );

local Category = "Shepard's speedway"

local V = {     
                // Required information
                Name = "Chevy Camaro", 
                Class = "prop_vehicle_jeep",
                Category = Category,

                // Optional information
                Author = "Shepard",
                Information = "camaro with an extra seat.",
                Model = "models/peterboi/Camaro/camaro.mdl",
--                Passengers  = { passenger1 = { Pos = Vector(20,20,13), Ang = Angle(0,0,0) } },
                SeatType = "jeep_seat",
                HideSeats = false,
                HeadLights = {
                    Light1 = {Pos = Vector(-20,-86,33), Ang = Angle(0,10,90)}, 
                    Light2 = {Pos = Vector(20,-86,33),  Ang = Angle(0,-10,90)},
--                    Light3 = {Pos = Vector(-20,-86,33), Ang = Angle(0,10,90)},
--                    Light4 = {Pos = Vector(20,-86,33),  Ang = Angle(0,-10,90)} 
                },
                Horn = {Sound = "vu_horn_simple.wav", Pitch = 90},
                Customexits = { Vector(-90,36,22), Vector(82,36,22), Vector(22,24,90) ,Vector(2,100,30) },
                ModView = { ThirdPerson = {Out = 200 , Up = 0} },
                
                KeyValues = {
                                vehiclescript    =    "scripts/vehicles/Camaro.txt"
                            }
            }

list.Set( "Vehicles", "Chevy Camaro", V );