Vertices keep moving out of place by themselves

I’ve been constantly having to move vertices back into place and I don’t know why.

When I saved my map about an hour ago everything was in place.
I saved my map, quit hammer and source sdk, then I played ep2 for a while.
Now I open my map again and vertices in random places are off the grid.

http://img194.imageshack.us/img194/4457/vertices01.jpg

http://img6.imageshack.us/img6/5715/vertices02.jpg

It only takes a few seconds to move them back into place, but I don’t want to do this every time I quit source sdk then open it up again.

You could probably just use clip for a simple ramp like it shows in the picture.

I’m not sure what all you’re trying to do with vertex manipulation, but clip might work better in simple cases.

It means that one of the the faces is not coplanar. When you re-load vmf, it’s automatically readjusting it for you. Do not ask how to disable this feature, I do not know and definitely would not want to. Actually, doing so will cause much worse consequences.

Like Sirrus said, try redoing that brushwork with the clip tool this time.

Hmm.
I clipped the brush diagonally so instead of 1 square face on top there are 2 triangle faces.

http://img694.imageshack.us/img694/8507/vertices04.jpg

The vertices don’t seem to move now when I quit hammer then open my map again.

Don’t use clip to stop this unless it needs to be concave.
Use the split face option in vertex edit mode.

ooh, I didn’t know about this tool.
Thanks.

The reason the vertices keep getting misaligned is because the brush you are making is very slightly concave, and Hammer can’t work with concave brushes. The brush may not look concave, but when the vertices do this, it means it is concave.