VERY annoying problem with Adv.Dupe and Massless thrusters!

So I was making mah battle ship and was using massless thrusters since they are perfect for my heavy ship! I wire em all up to my adv.dupe, go off Gmod to take a break, come back on, dupe the ship and see the horror that is all my thrusters have been unwired! I don’t have this problem with wired thrusters, but with them I need to set an idioticly high value and put a ton of them and I still get an avrage speed of 6 km/h -_-. Also for some reason Adv.Wiring doesn’t work on grabbers, but thats not so important!

Don’t make me bump this!.. Oh,wait.

Use normal thrusters and make them weigh more. The more they weigh, the more thrust you get, making you not need a ton of them.

Tried with weigh slider to the max, 3 thrusters to as high trust as it could let me (something over 20 billion, I belive). Bearly moved -_-

Let me correct mahself. It works on normal thrusters, not wire. But I NEED wire thrusters!

Also, use larger models.

As the scout would say:
“Uh… no!”