Very low FPS, any tips?

So, I rebooted GMOD after a long time of not playing it (steam said 6/27/2011), and it had trouble to load. I had to wait around 10 minutes for it to start.

I managed to get in-game, and after the map loaded GMOD was going really slow. I have net_graph set to 1, and it showed constantly 10FPS.

I don’t know why it is going that slow, it was a “clean” start, with no npc’s or props. Any ideas?

This is a screenshot of my addons folder, my map folder and there are my specs, straight from Speccy :

**OS : Windows XP 32bit SP3

Graphic Card : Geforce 8400 GS / 512MB (1440x900 res, always worked perfectly fine at full-res)

HD : 156 GB Western Digital WDC WD1600AAJS-60WAA0 (SATA)

Motherboard : MSI 0A90 (Socket 775)

CPU : Intel Pentium E2160 @ 1.80GHz (dual core)

RAM : 2GB DDR2**

As I said, everything worked perfectly fine and smooth before. Before quitting GMOD I’ve been using it in windowed mode, and, again, it worked fine, without any lag.

Can anybody help me? I tried to be clear as possible, not sure if this is enough.

Do other games perform as bad?
I can only suggest you to remove all your addons at this stage.

Yesterday I cleaned my registry with CCleaner. The game I’m playing most is TF2 right now, and it doesn’t have any performance issue, besides choking after map loading.

Will try

So you can get a bit better performance put


 -dxlevel 81 

in the properties of gmod.

The strange thing is, it used to work perfectly with dxlevel 90. I got around 100-90 FPS with a bunch of props.

Now, I deleted a ton of stuff (83 files) and re-verifying cache file.

After that I’ll start it normally in fullscreen. If it doesn’t work, I’ll try -dxlevel 81

[editline]14th July 2011[/editline]

Nothing, deleted even more stuff and lowered graphics, still 10FPS.

Trying DX8.1 now, will report later

Check if your video driver is up to date, I believe the last Nvidia update was on July 1st

That too, haven’t updated for a good while.

By the way, I solved the framerate issue thanks to DX8.1 . I still wonder why it decided to run like shit on DX9 tought.

Very low fps can have many reasons.

One can be that your computer is infected with a virus, so to be sure scan it with 2 up to date Antivirus scanners.

You could also have problems with a recently installed application that runs in background.
(Check your taskmanager for high mem Processes)

You could also suffer from high Fragmentation so just check that with Steam. (Ask if you don’t know how to do that.)

Last but not least your hardware could also be overheated (Its summer) or even defect, so just google “Speedfan” and check your temps.

Try adding -dxlevel 98 to your advanced launch options.

I use speccy, it constantly reports that everything is around 50-45C°.

I verified the game files, and I checked for fragmentation. 0% before and after verify.
I have de-fragmented my hard disk last night :v:

It’s only GMOD the game beign affected, only when it runs in DX 9. Strange, really.

Haven’t installed anything new since the last time I played Garry’s Mod, besides CCleaner, which I don’t think runs in the background.

About defect stuff, I’ve noticed this weird thing. After one quick power failure, Windows reported 1GB out of 2GB of RAM. Same did CCleaner but not Speccy. That might be it?

[editline]14th July 2011[/editline]

98?

What Direct X will this set? 9?

Will try and report back

EDIT : Why rate sponge dumb, he was just helping

It forces the game to use a newer version of DX9, which means better performance on DX10/11 capable machines.

[editline]14th July 2011[/editline]

One can be that your computer is infected with a virus, so to be sure scan it with 2 up to date Antivirus scanners.

Not a good idea.

You could also suffer from high Fragmentation so just check that with Steam. (Ask if you don’t know how to do that.)

That would end up with this message (It automatically starts when the game is very highly fragmented)

Last but not least your hardware could also be overheated (Its summer) or even defect, so just google “Speedfan” and check your temps.

The only possible part of his post.

That’s why.

My video card supports DX10, but probably can’t run a DX10 game.

Trying right now… Steam froze, so I’ve got to restart it

You’re running XP, meaning no DX10. But you might still get the benefit of higher-end DX9.

Knew about DX10 stuff, but I will try. Steam finally decided to re-start