Very low FPS in DarkRP

Hello,
I’ve been getting very low FPS (about 10-20) on the DarkRP server I play on. I’m not sure if it’s just me or if this happens to most people. I get about 550 fps with an empty map in single player on max settings, so I don’t see why when I play on DarkRP I get really low FPS, pretty annoying because I can’t play properly with such low FPS.

I have a brand new computer (about 2 weeks old), here’s the specs:
CPU: AMD FX-8350 4.0 ghz 8 core
CPU Cooler: Corsair H60i liquid cooler
GPU: Nvidia geforce EVGA GTX 960 2GB
RAM: 1x8GB @ 1866 mhz
Storage 240GB SSD, 1TB HDD
motherboard: Gigabyte ga-990fxa-UD3
PSU: 650W Corsair 80+ gold certified fully modular
NZXT Sentry LX fan controller
case: Thermaltake chaser MK-I
OS: Windows 8.1 full version 64 bit (genuine)

CPU core temps are about 25-35 degrees celcius while in-game
GPU temp is about 30-50 degrees celcius while in-game

Not sure if you guys need more information, if you do just ask.

Your most likely just playing on a server someones running off of their shitty computer. Try a different server and see if it’s any better. Check everyone’s ping. If they are all really high its probably the servers fault.

I tried another server, I still only get around 25-50 fps. Even with an empty server I still only get about 100 fps at max, but in Sandbox I get 550 with raised max fps setting. And the pings are all good, I get decent ping too because the server is also in Canada

Different server have different addons, whilst yeah you can say oh this server gives me better FPS and a better connection, it really depends on what addons their running and what shit they have out and what’s on the map.

Also whilst your specs are fine it’s down to code optimization of the addons being used and what is present on the map.

Yeah, true. If I took that stuff into consideration, it would be about the same FPS. The server that I play on has TDM cars and a bunch of other custom addons. both servers had the same map. Both servers also had about the same population.

Not always the same FPS. Different servers again. Basically what I’m trying to say is that you can’t have the same server, they’ll always be different so FPS, connection, scenarios are gonna be different. Which what separates the good optimized ones and the badly optimized ones apart.

With that going back on topic, ever server is different there is nothing you can do except find a server that doesn’t have terrible addons that cause FPS drops like what you’re experience. The hardware isn’t at fault.