Very weird fps problem

about 1-2 weeks ago when i bought Rust on steam it was perfectly playable for me i played on Fantastic graphics 1920x1080 60 fps, everything just maxed out.
so about 1 day ago when i wanted to play some rust again after a small break i launched it joined a server and 1-3 fps i have no clue what the problem is.
I’ve done everything to fix this but nothing will work and trust me Everything, checked for driver updates, grass.on false,-force-d3d11, -force-feature-level-9-3,2,1, lowered all graphics,windowed,Re-installed the game(so pretty much everything ive found on the interwebs I’ve tested).
and i bet some of you will tell me to wait for an update but what could the devs have fucked up the fps because i cant be the only one.

if you got any advice please help :slight_smile:

Have you tried waiting like one minute? I get unplayable fps when I just join a server because the server browser is still refreshing, once it finishes you’ll be able to play :slight_smile:

Anyway, I’m having like half the fps I used to have since last patch :confused:

it’s same for me… before patch i had min 40-70 fps, and now most of the time 20ish… barely playable…

and changing graphic setting doesn’t seems to do anything… disabling aa in catalyst, or crank it up, or let the game manage it’s the same…

and when i load server and when i i"woke up" i have 1 fps, but few seconds (maybe 10) and it’s ok…
that’s the servers listing i suppose…

i wanted to try and connect through console without listing servers, but servers are down so i cannot try for now :confused:

regardless… yeah - almost exactly half fps (or more) less than before…

Are you running windows 8?

win7
6950 2 gb
695 cpu at 4x 3.8
8 gb ram

Same here! I’ve literally tried everything…stupid patch. -_-

Make sure that your computer is using your High Peformance processor and not your onboard graphics card. This can be done for Nvidia graphics cards by;

  1. Right click on desktop and open NVIDIA Control Panel.

2.Select “Manage 3D Settings”

  1. Change preferred graphics processor to "High-Peformance NVIDIA processor and apply.

  2. Select “Set PhysX Configuration”

  3. Make sure that your selected PhysX processor is your graphics card eg… NVIDIA GeForce 770ti and apply.

Hopefully this will have fixed your problem and you will be free to play Rust again at beautiful settings that I can only dream of. :slight_smile: