View and World Models not showing.

Well, I’ve been trying to create my Pistol pack using Worshipper’s Realistic SWep Base but all the SWeps have invisible view and world models. The sounds are alright, just the models won’t show.
I’ve tried putting the models into the main garrysmod folder but still no luck.
If anyone knows how to fix this, please help :D.

Hmm the only reason that i can think of is that u have the model names wrong. Post me your swep.Viewmodel line of code.

Also ur world model. I will check it form there.

[lua] if (SERVER) then
AddCSLuaFile(“shared.lua”)
SWEP.HoldType = “pistol”
end

if (CLIENT) then
SWEP.PrintName = “Raging Bull”
SWEP.ViewModelFOV = 70
SWEP.ViewModelFlip = true
SWEP.Slot = 1
SWEP.SlotPos = 1
SWEP.IconLetter = “f”

killicon.AddFont("weapon_deagle", "CSKillIcons", SWEP.IconLetter, Color( 255, 80, 0, 255 ))

end

/---------------------------------------------------------
Muzzle Effect + Shell Effect
---------------------------------------------------------
/
SWEP.MuzzleEffect = “rg_muzzle_pistol” – This is an extra muzzleflash effect
– Available muzzle effects: rg_muzzle_grenade, rg_muzzle_highcal, rg_muzzle_hmg, rg_muzzle_pistol, rg_muzzle_rifle, rg_muzzle_silenced, none

SWEP.ShellEffect = “rg_shelleject” – This is a shell ejection effect
– Available shell eject effects: rg_shelleject, rg_shelleject_rifle, rg_shelleject_shotgun, none

SWEP.MuzzleAttachment = “1” – Should be “1” for CSS models or “muzzle” for hl2 models
SWEP.ShellEjectAttachment = “2” – Should be “2” for CSS models or “1” for hl2 models
/-------------------------------------------------------/

SWEP.Instructions = “Left Click: Shoot
Right Click: Iron Sights”

SWEP.Base = “zomb_base_pistol”

SWEP.Spawnable = true
SWEP.AdminSpawnable = true
SWEP.Weight = 5

SWEP.ViewModel = “models/weapons/v_pist_ragebull.mdl”
SWEP.WorldModel = “models/weapons/w_pist_ragebull.mdl”
SWEP.Category = “A Zombie’s Pistol Pack”
SWEP.Primary.Sound = Sound(“weapons/ragebull/deagle-1.wav”)
SWEP.Primary.Damage = 65
SWEP.Primary.Recoil = 7.5
SWEP.Primary.NumShots = 1
SWEP.Primary.Cone = 0.02
SWEP.Primary.ClipSize = 6
SWEP.Primary.Delay = 0.65
SWEP.Primary.DefaultClip = 6
SWEP.Primary.Automatic = true
SWEP.Primary.Ammo = “357”

SWEP.data = {}
SWEP.mode = “semi”

SWEP.data.semi = {}

SWEP.data.auto = {}

SWEP.IronSightsPos = Vector ( 5.15, -2, 2.6)
SWEP.IronSightsAng = Vector (0, 0, 0.0315)

function SWEP:Reload()

self.Weapon:DefaultReload(ACT_VM_RELOAD) 
-- Animation when you're reloading

if ( self.Weapon:Clip1() < self.Primary.ClipSize ) and self.Owner:GetAmmoCount(self.Primary.Ammo) > 0 then
-- When the current clip < full clip and the rest of your ammo > 0, then

	self.Owner:SetFOV( 0, 0.15 )
	-- Zoom = 0

	self:SetIronsights(false)
	-- Set the ironsight to false

self.Weapon:EmitSound(“weapons/ragebull/bullreload.wav”)
end

end

function SWEP:Deploy()

self.Weapon:SendWeaponAnim( ACT_VM_DRAW )

self.Weapon:EmitSound(“weapons/ragebull/bulldraw.wav”)
self.Reloadaftershoot = CurTime() + 1
self.Weapon:SetNextPrimaryFire(CurTime() + 1)

return true

end [/lua]

Heres the entire code for one of the swep.

Edit : http://www.fpsbanana.com/skins/950 Teh model.

use




tags, or the lua tags i don’t know

How?

[lua] [/ lua] (Without the space)

No, it’s [noparse][lua]Lua Code[/lua][/noparse].

Just edited it, now does anyone know a solution to this problem?

Oh sorry about my post, I didnt realise I put a / in the first tag.