View Clips Near Eyes

I wanted to make a script that lets you choose your size, useful for making maps appear bigger. One of the problems is, that there seems to be a clipping plane in front of the eyes, where nothing is rendered behind it.
[img_thumb]http://img843.imageshack.us/img843/2465/gmconstruct0003w.jpg[/img_thumb]
Is there any way to change that?

yes , my trird person script with the distance set to 1

[editline]06:45PM[/editline]

third

Change the FOV.

It’s probably due to the near plane being too far. I don’t remember any console command or Lua function which allows you to change it, so I guess you’ll have to ask Garry.

[editline]08:19PM[/editline]

You sure that’s a good solution?

I thought about setting the actual view origin behind the head, and decrease the FoV for that. Wouldn’t work that well on tiny sizes though.

[editline]08:27PM[/editline]

And let’s see if Garry finds this thread :v:

It works fairly well. Maybe not for the scale he is using.

Found that there is something called znear “Near Clipping Distance”. Could there be any override using **[Render.RenderView

http://wiki.garrysmod.com/favicon.ico](http://wiki.garrysmod.com/?title=Render.RenderView)** which uses Camera Data … ?

I love you.
I already was on this page some time ago, but I couldn’t remember znear.

Have fun

It bugs a little bit (rendering & postprocessing errors), I noticed CalcView in the source engine has znear and zfar parameters. Gonna try that now.

Please post your results if it works, I need something like this as well