VMPI support for garry's mod?

Hello there, has anyone of you sucessfully got vmpi to work with garry’s mod?
in that case, how did it perform? and how did you set it up?
thanks!

EDIT: got it working, workarround added in https://developer.valvesoftware.com/wiki/VMPI thanks for reading.

Why would you need vmpi?
I am not sure if GMod even comes with vmpi but source 2013mp does.
I’ve tried running vmpi for vvis on source 2013mp for a gmod map on around 24 cores and it looked like it was working, I canceled it because It was taking too long and I decided to just manually optimize the map(the visibility on that map was terribly optimized and i tried a normal compile and let it run for 6 days on 4 cores before i canceled it)

It some use cases in the Ep1 engine, but has been made obsolete in the OB engine.

VMPI is supported in all source engine games from the Ep1 engine onwards.

Turn on MPI graphics so you can see the work units being completed:

But it should not take 6+ days to compile a map unless you’re doing something wrong.

Hello, i optimized my map, from 1hs 30min compiling on my computer i got it down to 10 minutes utilizing 4 computers! (16 cores 32 threads) I added my workarround to the wiki so you can use it without any troubles! https://developer.valvesoftware.com/wiki/VMPI

The only reason i wanted to use VMPI is because i have a couple of computers in my place and i could put them to a better use… 0 problems, vrad works too.

(Sorry for bad english :slight_smile:

there is no vmpi.exe in the gmod bin directory,

I was using the mpi graphics, the map was rp_bracket(in case you were wondering), after manually adding visclustering the map vvis pass time was reduced to around 5 minutes so…

With proper visibility optimization, like func_viscluster, you can reduce any vvis pass down to nothing, vrad however is broken on the orange box branch if i’m not mistaken, you say vrad works too?
what version of source are you using to compile? I would love to complete a large vrad pass in a short amount of time with a bunch of computers.

Hello arrow1234, i’m using garry’s mod’s bin folder tools, and vrad works perfectly.

VMPI is not an executable, it’s functionality built into the compile tools invoked via command line flags.

VRAD only has issues if you run it from within Hammer. You need to run it in a command console or via a batch script for it to work properly.

http://forum.facepunch.com/showthread.php?t=1374587