VMT Fuckery: Wings have improper translucency

so many help threads from me, i wonder how many more i can make.

Anyhow, I’ve been having trouble as of late with a model that has multiple wings – 21 of them to be exact. They’re all feather-like and have this little golden part going down the middle of each and every wing. The only issue is?

(Model’s a heavy WIP still, don’t mind some of its seams)

The little golden parts that can BARELY be seen at the edges of the feathers are all covered up. With experimentation, I’ve attempted to use $ignoreZ. I thought it’d work, but then this happened.


That VMT code won’t work at all and I need another solution. Does it all boil down to deleted certain parts of the mesh? Because the wings are not one-sided, it’s more of a hexagonal shape. It may boil down to that, but I’m just wondering if there’s another way to do that before I ultimately have to do that. Help is greatly appreciated! Thanks in advance.

Source is not very good with $translucency render order. $alphatest is a bit better but it looks shittier.

I’ve tried $alphatest, but here’s the thing – what you see in the first picture is the model using $alphatest, so that isn’t going to work. I really wish Source was better with transparency, it’s honestly annoying.

you could try adding alphatest and $allowalphatocoverage 1
that allows the translucency to render partly translucent areas as well

That didn’t really work either – I’m not sure how to get the wings the same appearance as they did in the actual game.

Quick question - are you compiling with mostlyalpha, and seperating each of the planes you want to use with translucency into their own texture?

Now that you mention, it, no – not at all. I’m not exactly too advanced into porting models since this is one of the more complex ones, so I haven’t a clue about separating each of the planes I want to use with translucency into their own texture. You’ll have to explain that part to me in PMs since I don’t really wanna clog up this forum with tutorials. Or do whatever you want, it is your choice.

Basically source is notoriously bad with translucency. There’s a number of ways to essentially easy it in though.

a) each one way facing surface is assigned it’s own VMT (just drag and drop a differently named texture on the forward facing parts of the wings and another one on the backwards facing ones)
b) by compiling with the mostlyOpaque flag in the QC.

I have the latter thing in the .QC file, actually. The first, you might have to explain that into deeper detail because like I said, I don’t get most of these things right away and I need a more in depth explanation for some things. Sorry if this seems troubling, I just want to get this fixed somehow.