Voice chat problem - character freeze and ghost mode

I press “V” (or other key that binded to voice chat) and then game stops reacting on my actions. The only thing that i can do is to move, but other players don’t see me moving. They see me standing in the place, where i pressed “V”. It is like a ghost mode, but i can’t fly.

  • my hits with any weapon are animated, but have no result
  • i can’t open any container
  • i can’t switch the weapon and i can’t even hide the wielded

The cure is to disconnect and then reconnect, but when i press “V” the story is repeated.
Sometimes this is not happening, but i can’t find out what it depends on.
Please, help!

Running the game on Mac OS 10.9

I have this problem too!
And 2 of my friends!

Win 7 64.

PLZ FIX IT, cant play without voice chat (

Same issue here But mine is constant! even if I dnt talk it happens. It sucks because good luck getting blueprints when a zombie chases you and he hits the air 3 times while I’m shooting his face and I die!!!
They say u can reset but when it happens around others say goodbye to all your stuff since they have a good 15-25 secs to take it all.
Dont get me wrong I love the game and understand its in alpha but it’s pretty much pointless playing.
Once they figure out whats wrong and address the issue I will LOVE this game, but unti then Im dead in the water here.

I’m getting the same exact issue. I have a USB mic that’s being properly detected by the game, and no matter what I have the hotkey for voice chat set to, when I press it, it does this. Disconnect and reconnect fixes it, but voice chat doesn’t work which is very problematic.

Very very interesting developments, Let me look into it

also has this problem, use logitech g35 headset usb, but I didn’t use voice chat and don’t press V. After 30-60 sec when I joing server I get flash backward and turn to ghosting.

Is it confirmed that this has nothing to do with a firewall or router? i.e. have you enabled DMZ mode on your router set to the IP of your computer? have you tried direct connecting your modem to your computer?

I don’t use router.

upd:
But anyway it seems network problem, coz without g35 problem still be.

Helk this happens on my friends Mobile 3G connection he uses to tether to his computer.
Here is a video of how bad it is, not sure if DMZ does anything.

Same thing happens to me without using my mic. I play for around 15-30 seconds and then anything i do from there on doesn’t seem to register. I go to gather wood and it doesn’t work, loot something, nothing works. Then when i log off and then of I am back miles away. I can still hear people talking and shooting but they are frozen in place.

bump

Ye also today we can’t play. The problem is explained, can a Devs answer? Just for a ensurance of notified issue.

I had this one too, could not open boxes or harvest while ghosting. Followed me through death, both camp and random respawns. Falling still affected me. But animals/zombies did not react. Radiation would slightly be affected. Meaning in the center of a rad zone it would occasionally spike to 80 or so then fall slowly. Still had hunger.

Tried a few game restarts but still had the bug each time. Then tried other servers and could not join, then could not join the original server(no response when double clicking).

Steam/Win8.1

Going to try uninstall/reinstall in steam now.

::Update::
After reinstall I am finding only 11 players one 1 server so I am assuming everything was shutdown/restarted…?

BUMP! any solutions???

Helk: I too have this issue and have created a thread Here ( <— click ) for a more thorough detailed approach. The video posted is exactly as it should be and you guys have addressed this is a major issue. Hopefully you guys will have this hotfixed super quick before it gets even more out of control. I personally think taking out VoiP from the game would be a step in the right direction, seeing as it tends to happen to those who use the VoiP portion within the game, but happens to me as well fairly regularly.

Well, I get that too but it is not hardware related as far as I am concerned.

It seems to be server related somehow as I have this issue on most servers exactly as described by Eldar_Sad but not on other servers.

My voice chat works just fine on Official Singapore server for example and that is one of the reason why I have made it home even though I am in Europe (High ping).

I have also noticed that it has nothing to do with lag/internet speed/Ping/firewall as I tested on a few European servers (low ping for me) and I get the problem immediately upon pressing V and the game is always launched from the same PC using the same router/internet connection.

If you guys want I can do some tests on the Official servers and let you know on which ones I encounter the problems and which ones I do not so that you can have a look at the server settings maybe?

[added]1391991203[/added]

Sorry forgot to mention:
RUST on PC
Windows 7 64bit
Has been happening since I got the game and still persists on latest update Feb.08.2014

I get the same problem. As soon as I press V (or any other key bound to voice chat), I cannot open anything or change weapons. I also appear to stand in one spot to other players, although on my screen I am free to walk around. I have tried a Logitech USB microphone as well as WO Mic for Android… Both are working in Steam, but both cause this problem.

And, as with others, this problem occurs on most servers, but not all.

I would be happy to help debug this issue, and can provide any additional data if needed (or try any workarounds or fixes).

i have this problem too and i very bored too disconnect and reconnect but i never use voice chat in this game

I decided I would try out some official servers, to see which ones ghosting happens on. Not sure if this is helpful, but this is what I observe:

US East Coast 2 - Working fine
US Central 4 - Ghosting occurs
US central 2 - Ghosting occurs

Hopefully the cause of this problem can be identified.

I found a pattern on this at least for me it happens mostly when i play on modded servers, if i join vanilla ones it works perfectly.