VoiP Microphone issue (Can't use it, maybe an input problem in UnityWebPlayer?)

Hi there !

When I launched Rust for the first time, I allowed the use of my microphone in the Unity web player
But I can’t use it in proximity voip

Problem :
-I tried to use Voip with a friend, to check if it was working, and I was on teamspeak with him during the test : He heard nothing in the game

Facts/Context :
-I changed the attributed key (V) several times.
-I checked if my micro was on “default” in windows, it is, and it works with Teamspeak and other programs without any modification of the input.
-I searched on the web how to change the default microphone in UnityWebPlayer (Something like a config menu) but i just foud dev stuffs on how to use the micro in your game…
-I can’t find nothing about my problem on this forum.

**
Questions :**
-Do you know how i can check what input is used by the player ?
-Do you…have a solution?

Sorry for my english, as you can see, it is not my maternal language

Thanks, See you in game :slight_smile:

Zewho

Open the console (F1) and it should tell you what input device it is using upon connection.

Have you entered a command in the console ? This is what I can see in mine, only that :

http://image.noelshack.com/fichiers/2013/42/1382176267-capture.png

No, it should say so when you are connected to a server. Weird. Try to get the enable microphone modal again.

reinstall unity

I tried it several times,

-with the 32 and 64bits version, can’t get the enable microphone modal again, even if I uninstall all the previous versions

-I tried with Chrome, Firefox and Firefox nightly.

No changes !

Sorry to up this topic… Maybe somebody will have a solution now ? I can’t be the only one to have this problem :slight_smile:

I tried everything below a lot of time, even tried to uninstall my sound card, and tried to use another one.

It seems that I can’t reset all the unity’s parameters, somebody now how to do that ?

Thx !

I found a “solution”. I used a voice changer and set that as my default microphone in windows. Problem solved. And now I can creep people out in the dark :stuck_out_tongue:

Hi Bstriker ! Are you using a third party software (what software?) or directly the windows mixer ??

Thx :slight_smile:

Thx Bstriker,

-I installed MorphVOXPro4 trial version
-Putted it as my default micro
-Started and closed rust
-Putted back my “real micro” as default

It worked !

See you

I was going to mention that the voice chat they use relies on having your Microphone set as the default recording device in Windows (before Rust launches, doesn’t work if you set it during). It does support changing the recording device, but they don’t seem to have an option for it.

Oddly enough, having actually wrote the voice chat (as a plugin for other Unity developers to buy, as Rust did apparently), in my own tests it detects my microphone just fine (records and everything), but in Rust I seem to have difficulty with voice chat.
Giving it another shot to see if it picks up my microphone…
EDIT: It says it does, " FrontMic (Realtek High Definition Audio) " which is the mic I expect it to use…