VRAD crash problem

Hello there !

I’m actually confronted to a problem when compiling my map with Hammer.
I’m using Fast preset. VBSP and VVIS are running fine, but when it comes to VRAD, it stops working after ~30secs.
There isn’t any compile-breaker stuff in my logs (for my opinion). Take a look here (I know for the materials)

Do you guys have any clues about this ?

Regards,
H0lidays.

Try fixing the part where lights have a greater 50% distance than 0% distance

Patched all of them.

VRAD is still crashing at the end. It generates a MDMP file in the bin directory, but the size of the file is 0 Ko.

EDIT : Edited the path so it has no spaces, same stuff again.

how many of your lights are named? and how many lights do you have? Would you mind PM’ing me the vmf?


WARNING: Map using power 4 displacements, terrain physics cannot be compressed, map will need additional memory and CPU.

use power of 3 displacements, if you need better looking displacements make the brush you change to a displacement smaller i.e from 512 to 128 units,


 Error loading studio model "models/deadbodies/bodies96_a.mdl"!
Error loading studio model "models/deadbodies/bodieshall96.mdl"!

change these to prop_ragdolls


make_triangles:calc_triangle_representation: Cannot convert

i’m guessing this is is a corrupt displacement and you’ll have to remake it


26 degenerate faces and zero area child patch 

are corrupt brushes and could be causing probs with vrad and they’ll need to be found and remade

Those Don’t cause vrad to crash.

I couldn’t tell you how many of them are named, but I know there are 286 lights on the map.
I asked one of my friend to compile it on his PC and it worked, but apparently when I do it on mine it constantly crash.

You should have receive a PM with a link for the VMF.

Got new stuff again.

I tried to compile the map w/o the materials, and this time it worked.
Compile logs : https://pastebin.com/ywMgLNZk

I made a backup of the map, and then I replaced all of the missing textures to some default material. Then, I tried to compile it and it didn’t work. Could be affecting VRAD, idk.

News again.

It does compile when replacing invalid material with “light” material (I tried only /metal04), but doesn’t when replacing with a heavier one, like brick.
I don’t know where this comes from.