VTA import - now working (indirectly but it works!)

Well… first of all… download the app to make it possible at http://l0nk.org/vtaapply.zip (source code for Delphi 2009 is included) …
because now a wall of text will start where I just quote the readme file included! If you do not want to read it… not my problem! I will get to a real life example WITH COLOURED SCREENSHOTS (colour by Technicolor and powered using your monitor) after that blue quote readme block.

Okay… we got that covered… and probably noone read it… so let’s get to the:
Real Life example

I did lose a 3ds MAX file… now I have an SMD and some VTAs… and would like to continue working on them… bad… for 3ds max 8… I won’t find a VTA importer - only an exporter.

For this demonstration I will use an Amy Rose model (Sonic character) I did port before… we’re going to be using the vertex animation for the blinking left eye:

So first of all, I open vtaapply.exe - it will ask me to select the original SMD file:

http://l0nk.org/vtaa01.png

Okay I double click amy.smd and it’ll show some model statics. Then Il have to select the VTA file.

http://l0nk.org/vtaa02.png

I select blink_l.vta - again some VTA statistics will be shown to prove the import worked. And it will ask me which VTA frame I plan to import… VTA frames are described in the readme, the way they are used depends on your VTA exporter… I used 3ds max to make my VTA file so I’ll select the last frame in the list!

http://l0nk.org/vtaa03.png

Now it’s applying the frame data to the SMD file it keeps in its memory. This takes up to a few seconds and then I’m asked where I want to store the new SMD file with the applied VTA file to:

http://l0nk.org/vtaa04.png

Okay… that’s the part vtaapply.exe does.
Now we’re going into our favorite modelling application (3ds max 8 in my case) and we’ll import the original SMD into it (including skeleton, textures - import everything):

http://l0nk.org/vtaa05.jpg

(materials were applied manually… the white models are kinda stupid to look at, thus I did that)

Now I’ll additionally import the one with the VTA file pre-applied… this time the skeleton should not be imported (in case of 3ds max 8, untick “Import skeleton”)!

http://l0nk.org/vtaa06.jpg

Now let’s add the Morpher modifier to the original model… and try to select the new model as morph target:

http://l0nk.org/vtaa07.jpg

Success… morph target accepted… now I can delete the VTA added SMD file…

http://l0nk.org/vtaa08.jpg

Now I have a MAX file with the added morpher again! So now… let’s get back to modelling!

Cool, thanks a lot.

Awesome, thanks.

Sweet.

This looks incredibly useful, thanks a lot. :smiley:

I was thinking link, would it be easy to make a VTA exporter?

like open a smd as the main model. then import a series of other SMDs to create a new VTA file. this would largly benefit milkshape users such as luigimario who use MS3D exclusively for all there ragdolls.

as milkshape currently has no VTA support. a seperate vta creator would mean your 3deditor would only need smd support, and thats it. vta could be handled in a seperate program.

-anyway just a thought. I’m on 3dmax, always will be. just thought this could be useful to others.

I think wunderboy is working on a 3ds max vta exporter. He said it’s in a hacky state at the moment but apparently working.

no, I have a vta exporter for 3dsmax already. I wasn’t talking about me

If you get a VTA import in XSI then you’d be my hero for the rest of time

@mm3guy: the app should work fine for XSI - it simply merges a VTA into an existing SMD… so you result with two SMDs… that should work with all modeling applications which can import SMD… I just do not know if XSI does flexes via morphers the way 3ds max does it… if it does not, then it most likely do not work

@mario_kart: see my answers on MSN :wink:

Reupload please …

Hey man this is great I really needed that tool and I can’t find anything else for importing the expressions in a 3d package. Can you please upload it again cause the link is not working anymore.

http://files.filefront.com/vtaapplyzip/;13923526;/fileinfo.html

Great Thanx man :smiley:

Doubtful, but can anyone re-reupload this? the link died again for me.

See post #13.

I said RE-reupload, your one doesn’t work for me anymore.

[editline]04:35AM[/editline]

File is Unavailable.

The file you are attempting to download is not currently available on our servers or is being processed. Please try your download in a few minutes.

fyi I tried it last month and again twice today, so I don’t think it’s coming back

Works fine here. I’ll upload it to yousendit.com

Edit: http://www.yousendit.com/download/ZW9CUXVpd0k5bEN4dnc9PQ

Thanks chum

all links are down please re upload :frowning: