VVIS.exe compiles 0 numportals

This just started happening, I looked around a bit and couldn’t find anyone with the same problem. It doesn’t fail to run, it just doesn’t compile anything. Here is a log of what it does.

"-------------- Start Compile VVIS ----------------
VVIS Started, Please Wait!

VVIS: c:\program files (x86)\steam\steamapps\aussieroo\sourcesdk\bin\oran gebox\bin\vvis.exe -game “c:\program files (x86)\steam\steamapps\aussieroo eam fortress 2 f” “C:\Program Files (x86)\Steam\steamapps\aussieroo\Valve Maps\house”

Valve Software - vvis.exe (Oct 25 2011)
2 threads
reading c:\program files (x86)\steam\steamapps\aussieroo\valve maps\house.bsp
reading c:\program files (x86)\steam\steamapps\aussieroo\valve maps\house.prt
1 portalclusters
0 numportals
BasePortalVis: 0…1…2…3…4…5…6…7…8…9…10 (0)
PortalFlow: 0…1…2…3…4…5…6…7…8…9…10 (0)
Optimized: 0 visible clusters (0.00%)
Total clusters visible: 1
Average clusters visible: 1
Building PAS…
Average clusters audible: 1
visdatasize:14 compressed from 16
writing c:\program files (x86)\steam\steamapps\aussieroo\valve maps\house.bsp
0 seconds elapsed

Compile Complete for this module.
VVIS Completed: Thursday, February 09, 2012, 1:33:02 AM
VVIS: Compile time: 0 seconds elapsed"

  • I made sure it wasn’t something I added or changed to the map by cordoning off an area I hadn’t made changes to for hours. restarted steam, rebooted, no dice.

  • I tried deleting vvis and replacing it by verifying the game cache, also replaced it with the one from the gcf, no luck.

  • I tried that compile checker on theinterloper and it only found a displacement abuttment and that’s something that’s just going to happen.

  • I made a brand new map to test, nothing but a spawn point, light, and some brushes to chop it up a bit, and it’s doing the same thing. No portals, but no error, no issues with the map, something is wrong with either hammer or vvis, and redownloading both wont fix it.

  • I Deleted local game content for the entire source SDK, and deleted the sourcesdk and sourcesdk_content folders…redownloaded everything, reinstalled. No dice. This has nothing to do with my map and it just started happening out of nowhere. steam didn’t update when this happened, I didn’t make any changes to any files, etc.

  • I also tried compiling the map in episode 2 and also made a brand new episode 2 map…no luck. So it wont work compiling it for TF2 or episode 2…

  • I completely re-installed the entire source SDK, made sure to verify the game cache on all Orangebox games and the SDK. I mean… If VBSP runs correctly, VRAD runs correctly, and this problem occurs on any map, in any game… It has to be VVIS, right? I can’t find a single other person with this issue, nor can I find any other feasible way to fix it. I dunno what there is left to try. This is extremely frustrating.

Any insight would be amazing, thanks in advance.

What are you compiling the map on? Like, what mode are you running BSP, VIS, and RAD on?

I’ve done it on fast, full, and final. Used the hammer compiler and vbct.exe, done it on hl2: ep2, and tf2.

Now to add my my frustration, after 3 days of this happening, and having not changed a single thing, it just stopped doing this and it works fine now. Sounds great, but that means I have no idea what caused it, I don’t know how to prevent it, and I wont be able to fix it next time around.