WAC Being retarded

So, recently I’ve installed the plane mod (Known as WAC, Only the first original pack) and when I spawn one in it:
Floats in the air,
Leaves a wheel prop after deleting,
Makes the noise when active (Forever),
Permanent No-Collide (Even after reseting collisions),
And of course its not enterable.

Any help is appreciated. Heres some screen shots.

http://images.akamai.steamusercontent.com/ugc/620723145145370056/4755FAC115AD0ED9AFD47E2E3EFEF05AD39E5154/

I forgot to mention this, but im getting this error

[ERROR] addons/wac/lua/entities/wac_pl_base/cl_init.lua:47: bad argument #1 to ‘tonumber’ (value expected)

  1. tonumber - [C]:-1
  2. unknown - addons/wac/lua/entities/wac_pl_base/cl_init.lua:47

Contact the author?

Im pretty sure it wouldnt help, because it works in single player. Im thinking its ulx but
i removed it and its still doing it. Ill just try to reinstall my addons one by one and see if that helps.

:what:
That does not have any fucking sense.

Try doing the addons thing, and if its still not working, its a problem with the addons and you should try to contact the author

Im not sure at this point. Ill reinstall all addons 1 by 1

Then contact the author and tell him the error and that it only happens in multiplayer?

I can tell you from personal experience that WAC has a lot of issues. Attempted to run it on sandbox multiplayer for a few months and it would crash things left and right. Players would have to be extremely careful with using it. Even went into the Lua myself and fixed a few bugs, but there are a lot. Contact the author as everyone else said, about the only way you’re going to get anywhere unless you know how to read the code and fix things yourself.

Also, you have to look at what you have installed. WAC will bug out with some other addons. So if you really want to see if it’s WAC itself, or another addon causing issues. Uninstall all addons, then install WAC ONLY, and run the server by itself with just that. Then slowly add the others if the WAC only install didn’t cause what you’re experiencing.

If I am correct, the author of WAC left GMod. I may be wrong tho

How did you install WAC? (Manually (as a legacy addon)? Workshop?)
Post the link.

I do believe it’s just multiplayer, as it worked fine for me in single player then when looking at it on any multiplayer server it’s just a glitchy mess with errors.

Is it completely necessary you use wac? I mean their are 1 or 2 other plane packs wich actually work, and their vechiles not entity’s.

WAC is outdated and unmanaged, you can use other alternatives like NeuroTec but your players are gonna have to download the content seperately (it’s a few gigs for all the models if you want all the packs)

Welp. Nuerotec is waaaaaaaaaaaaaaay too big. Probably, no.