WallWorm Collision Meshes

I’m having issue with collision. The mesh is a loop, as on you’d see on a rollercoaster or Sonic games. Anyone have any advice? I tried breaking it up and the element thing, but it didn’t seem to work.

http://dl.dropbox.com/u/32409323/screenshots/mesh.png

http://dl.dropbox.com/u/32409323/screenshots/badcoll.png

You might have more luck in the modelling section.

Tick the $concave button in the collision model & physics

I did, but still gave me that single hull mesh.

Have you seen this video?
Go to about 7:18

I’ve tried that too. I’m going yo try to make a different mesh and see if it works. I’m using 2013, so I don’t know if that’s a issue or not. I got the model from a different game, Sonic Colors to be exact, so I wonder if that has to do with anything.

2013 has a bug that breaks the Quick Hull function in WW. So all the pieces have to be created and convex manually in 2013 until that bug is fixed in Max.

I recommend Max 2012 until that’s fixed :\

If all those pieces are convex… then make sure $concave is checked like mentioned above. Also, after the collision meshes are assigned to the WWMT helper, make sure to use the Process CM function in the Collision Hull rollout… That function applies the needed smoothing groups and materials to your CM.

If there are a lot of hulls, you need to set the Expensive Collision Hull handling setting in the global WW settings to the one appropriate for your mod.

:slight_smile:

I have learned that you can now use the Quick Hull function in Max 2013 if you are using the right version of the nVidia PhysX Plugin for 3ds Max . I installed PhysX 2.85 (with which the latest Rayfire is compatible) and the broken function in 2013 is fixed.

Ah, Okay. Awesome.