Wanna fix this R9 380 problem or not? It's getting old

It’s really getting old that most of us with R9 380s and other cards with same drivers aren’t able to play Rust right now. Haven’t been able to play for 2 months w/o bluescreening and some haven’t been able to for almost 5 months. You all ever going to fix this? I’d really like to be able to play Rust again. After a few mins of being in-game either monitors just go out or I blue screen(Video Memory Management Internal). Same a-TON of others. Would REALLY appreciate it if some DEV got back to me on this and that you all would fix this. . . I miss playing Rust. I’m a dedicated long time Rust player(1600hrs). Please fix this.

I’ve tried TONS of different things trying to self fix this, but I don’t think there is anything we can do. I think this is just going be something you all have to fix.

Specs.

CPU: AMD FX™-8120 Eight-Core Processor~3.1GHz
GPU: AMD Radeon R9 380x 4G
RAM: 12G DDR 3
-Ask if there is anymore info you’d need.

I and the exact same issue with my R9 380 4gb but playing in dx9 fixed the problem for me
, I know it’s not ideal but atleast it plays. I have to agree though we need this problem fixed as it is affecting so many players.

I just bought the r9 380 4GB.

The only time there was a problem was when i first installed the card. Initial boot got me an error: Video Memory Management Internal. Basically, the system didn’t register the card due to no drivers installed? I let it have the disc that came along with it, which installed the driver for the card. I’ve had no problems since. (havn’t installed any new drivers off the internet, only from the disc as of now)

Playtesting was great. Though, the game has fps spikes (not to confuse with stuttering: visual “twitching” that affects the sense of movement), still. Should i be worried, or is that the effect of Alpha?

-----------------Edit-----------------
Display driver has crashed twice now. And i’ve tried to play this game twice in total with this new card for about 5 minutes in each session. Apparantly, i already had the latest drivers with the disc. Havn’t done much of troubleshooting yet.

-----------------Edit the edit -------
Apparantly, i already had the latest drivers with the disc - NOT. The disc installed version 15.11, the latest version, however, is 16.150… But who cares, i found a solution for my problem - see if it’s the one for you aswell (one of my comment somewhere below)

It only happens randomly to some players using the GPU, my first month with it was fine and then out of nowhere the problem just started happening. DX9 does fix the problem but is not an ideal fix as we spend money on a GPU only to have less powerful/shittier GPU’s not having the issue that we have.

Wait wait wait. You all getting a blue screen? All of you have the same gpu?

[editline]23rd April 2016[/editline]

What OS you using???

Good news!

I managed to fix the problem on my end. Hope it helps you too! (it’s to do with TdrDelay; TDR - Timeout Detection & Recovery)
It was supposed to be 2 seconds by default, but it looks to me my system didn’t have anything (which i believe equals to 0 seconds) - you’ll understand why it matters once you check out those links below.

Here are the links i first found the suggestion from(1), and how it works(2):

  1. https://community.amd.com/thread/192811 (I personally needn’t [didn’t need to - that needn’t just clicked or felt right all of a sudden] get rid of 3rd party programs mentioned in the link)
  2. https://community.amd.com/thread/180166

If it doesn’t work for you, do check again, just in case, you may have done something wrong by accident… otherwise you’re probably out of options. If it did work, leave feedback for others to see!

I can confirm it now - i’ve done some stresstesting (that before triggered the driver to not respond, and shortly after recover), and it now runs perfectly fine!

I have tried setting the Tdr delay to 8 seconds and it didn’t work. This was one of the very first things I tried.

Glad i was lucky enough for such a little tweak to fix the problem on my end, i guess. It could always start crashing again any time i play though - time will tell.

Dx9 has been the only fix to the problem on my end, I have been living with this bull shit for almost 5 months now.

I didnt had that problem before I upgraded my system.

Playing in dx9 now aswell. Actually I don’t see a difference from dx9 to dx11. I guess people just like bigger numbers.

Same issue for me. Made a reddit post about it a few weeks back with even more people with the issue…its getting beyond a joke at this stage. When I accidentally start in DX11 I have better FPS but max it’ll last is 5 mins before it crashes.

If someone from facepunch can even take a look at the crash reports to see if they can see whats wrong it would be something but there has been no communication regarding it

This has been ongoing for a few months and is not a Rust issue, you need to direct your complaints to AMD, as you can see from the following post people are having issues with a multitude of games such as Fallout 4, Dark Souls 3 etc. and no response so far from AMD …

You could try installing http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx which is helping some people.

I tried the 15.11.1 drivers for around a half hour and had no crashes.

EDIT: I played some more the last days and not one crash.
15.11.1 drivers really fixed it for me.

Need to update on this… The crash is back, no doubt.

I’ve put alot of effort, all sorts of “solutions” gathered across the web regarding this issue, and all i’ve managed to do is get 4 variations of the same problem:

  1. Display driver has crashed & recovered
  2. Application has been blocked from accessing Graphics Hardware;
  3. HDMI no signal;
  4. Black screen.

With all those “solutions” in place, i get to play a little longer before it crashes, BUT at the cost of gradually lower performance. I guess with all the “solutions” (yea, im not gonna list them all…), the crash somehow gets postponed until the card just can’t handle anything anymore and starts to bog down the whole system, and eventually crashes in one of the 4 ways. (i think the order I’ve presented them in indicates the severity of the crash, at least that’s how it feels inbefore the crash).

Did you try what I posted?

Also disable raptr. I started recording with plays and had raptr running, boom black screen crash. Closed raptr and after that no crashes.

I think i did, and it worked… for some time. It wasn’t as bad as with other drivers for sure. I’m not sure why i didn’t keep to it though, i guess i was in the middle of trying out all kinds of solutions. Maybe the performance wasn’t as good and that’s why i changed from this old driver? ehm… I’ll give it another try - better than crashing.

There is a temporary fix: https://www.reddit.com/r/playrust/comments/4hg157/fix_for_amd_r9_crashes_temporary/
written by me

Nice but for me it’s enough to use 15.11.1 and remove or close raptr.

Roll back a drive

I have the R9 380 and basically every game runs like crap and had problems for so many things, namely fallout 4 crashing in rain which took like 10 months for them to patch. I think this card is garbage is the problem.