Warning: Command too long... ignoring!

First of all, sorry if this is in the wrong section I had no idea where else it would go. Was going to put it in the Help & Support section, but it cleary stated only post if you have trouble PLAYING Garry’s Mod.

So, I have this problem where I’m trying to restrict a ULX group with its adduser command, I want it to only be able to add to certain groups. It works, but up to a max and after this max of groups, when I press “apply restrictions” it will do nothing, but if I check the console it will say “WARNING: Command too long… ignoring!”, followed by the rest of the command.

So the question boils down to: How can you bypass the “WARNING: Command too long… ignoring!”?

Thanks in advance!

:snip: Probably wrong

Oh! Good idea, I’ll try that.

EDIT: Didn’t work.

post the command perhaps

or every option you are changing

maybe try changing little bits at a time before pressing update

OR

you could go to data/ulib/groups.txt and modify it manually, could work

Yeaah… XGUI is using ULX console commands (limited to 255 characters) to pass the access string. The best solution would be to open up your data/ulib/groups.txt file, set your accesses there, then do a changemap on your server.

An example would look like this:


		"ulx adduser"	"* <group1,group2,group3,group4,group5>"

(Where * is the value you want for can_target.)