Warning : Overflowed writing uncompressed string table data for downloadables

Hello there,

now that my problems with the FastDL server are gone, I try to install the Spacebuild gamemode on my server but I have a little (big) problem with the resource.lua file.
As the title says, I got this error serverside when connecting to the server. Then, any file is downloaded (It announces about 4500 files to download but the bar grows really fast and I’m connected with 4400 files left to download)

Yup, I know, I’ve got many many files to download (At the beginning it was more than 6500 files !) but I only put Spacebuild and wiremod, nothing more…
I won’t show you my resource.lua file cause it’s as long as I’ve got files to download, but trust me, it’s well done :slight_smile: (It worked when I only had Spacebuild, there was about a thousand files, and no problem)

So, if someone knows how to fix this, it would be great :slight_smile:

Thanks,
Gyoo.

I’ve never ran across this error myself, but guessing from the name of it, it looks like your overflowing the list of files it will send to the client.

For starters, forcing clients to download over 4000 files is a BAD idea in general and just a mess to deal with. Large content packs such as Life support, Wiremod, SBEP, etc should be not added to the download list. Players on your server should download those on their own… preferably with an SVN client.

You may not like the idea of that but anyone who joins your server without one of those packs wont want to wait for 1000’s of files to download, let alone if the content pack is ever updated it would be a major headache for you to deal with.

So chances are, you are just overloading the download list, reminds me of the old Lua string table overflow bug…same concept at least. Try to cut down your resource list, only include smaller packs or your own custom content.

Just one more thing I want to point out, if you adding lua files to your resource script… you do not need them, any lua that a client needs is sent via the Lua Cache file.

I hope this helps a bit.

He does present a good point, you don’t see gmod servers have WireMod on there FastDL because they expect them too.

Thank you for your answers.

I guessed that it was a problem with a too long list of files to download, too.
So, I think I’ll do as you tell me to, letting all the big addons clientside and smaller addons serverside with the FastDL.
I should put ads in game to alert that some addons are required clientside, shouldn’t I ?

And last question : what if the addons aren’t installed the same way clientside and serverside ? (Explanation : to resolve my problem with the fastDL server, I put every file of each addon directly in the game directories, not in a folder in the addons one…)

Well then, I put SpaceBuild and Wiremod into the addons folder, removed the resource.lua file, installed the addons clientside, and then it seems to work.

Yup, seems only, because I have a problem with the physics of the spaceships… I can walk through them, and the console alerts that it can’t create physics for this model (for each model in fact).

Also, I can’t manage to make the files downloading directly from the addons folder.

Many problems, sorry about that…

Are you running SRCDS on a Linux distro? Certain addons have problems because Linux is a case sensitive OS and some addon devs like to use different casing for files and directory names in their addon.

If you are up for it, test it out by changing all the folder and file names to lowercase, see if you have any luck.

If you are running Windows and experiencing this error, post some of the console errors and we can try to do a little research on it… as I’m not sure what would be causing it at the moment… but that’s nothing trial and error can’t fix.

Files and folders in an addon are just emulated, making it easy to manage them… instead of adding everything to the root folders, which could get messy fast.

For example if you want to force send a model from an addon, the file path may be:

addons/<addon name>/models/somemodel.mdl

You would use models/somemodel.mdl instead

with resource.AddFile it would look like



resource.AddFile( "models/somemodel.mdl" )


The rule above also applies to uploading files on FastDL server, you should not have an addons folder on the FastDL web space.

I get a bit repetitive with posting these links, but they should help you out some.

My Tutorial Attempt

sv_downloadurl on the GMod Wiki

Ah, I have forgotten again to say that I run on Debian (dedicated server).
For the case-sensitive folders, there’s no problem about that, I use the command shown here to get all the paths to the files in a second :slight_smile:

And for the addons folders, I have tried what you tell me about this, but, well, I should explain a bit more : when I connect to the server, it prompts me a number of files to download (at a moment it was abot 160 files to download) but seems to ignore it and loads the downloading bar in a few seconds. I’ve tried many things, placed the resource.lua in many different folders that could fit, but the files keep being ignored. I’ve checked, and normally all the files are well placed.

When I got much time, I’ll make some tests again. I’ll tell you more then.
Thanks.

[editline]20th December 2011[/editline]

I installed other plugins to complete the SpaceBuild gamemode, but I think the main problem remains from SpaceBuild…

Any props from this addon/gamemode prompts when clicking on it from the game menu, or when it prompts, it doesn’t have any physics.
I tried to follow the steps they give on their website :

Didn’t work. Then I removed the SBEP folder, letting all the subfolders (5 addons) on the addons one, it worked better : I could prompt props, but no physics… Here I am, can’t do better.

And the problem with the files that don’t download seems to be fixed. Thanks for this part.

Hail to the bump o/