Water disappears whenever I add any func_details to the map..??

Hey guys so I am trying to add buildings or really anything to my map. Whenever I try to do this the water disappears. As soon as I delete whatever I added it comes right back. This program REALLY hates me. All suggestions are 100000% appreciated. Thank you for all suggestions. Also the only thing I have in my log is findportalside: couldn’t find a good match for which brush to assign to a portal near (0.0 -25.2 26.3). It points to the 0,0,0 axis thing (sorry I don’t know what it’s called). I tried to recreate the skybox if it is a leak, but nothing can fix this it seams like. Please help!




** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\bin\vbsp.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\hl2" "C:\Users\RD\Desktop\Mapping\CODE\gm_laubuild_d.vmf"

Valve Software - vbsp.exe (May 15 2014)
4 threads
materialPath: C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\hl2\materials
Loading C:\Users\RD\Desktop\Mapping\CODE\gm_laubuild_d.vmf
material "maps/rp_medievalrp_v2/wood/woodstair002a_-160_-680_1352" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/WOOD/WOODSTAIR002A_-160_-680_1352
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
material "maps/rp_medievalrp_v2/tile/tilefloor020a_-160_-680_1352" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/TILE/TILEFLOOR020A_-160_-680_1352
material "maps/rp_medievalrp_v2/tile/tilefloor001b_-1256_4352_264" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/TILE/TILEFLOOR001B_-1256_4352_264
material "maps/rp_medievalrp_v2/metal/metalroof008a_-3488_-2944_1208" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/METAL/METALROOF008A_-3488_-2944_1208
material "maps/rp_medievalrp_v2/metal/metalroof008a_-3616_-2976_1600" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/METAL/METALROOF008A_-3616_-2976_1600
material "maps/rp_medievalrp_v2/metal/metalroof008a_-3744_-2944_1208" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/METAL/METALROOF008A_-3744_-2944_1208
material "maps/rp_medievalrp_v2/wood/woodwall016a_-3744_-2944_1208" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/WOOD/WOODWALL016A_-3744_-2944_1208
material "maps/rp_medievalrp_v2/tile/tileroof004a_-3616_-2976_1600" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/TILE/TILEROOF004A_-3616_-2976_1600
material "maps/rp_medievalrp_v2/wood/woodwall016a_-192_128_600" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/WOOD/WOODWALL016A_-192_128_600
material "maps/rp_medievalrp_v2/wood/woodfloor007a_-3616_-2976_1240" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/WOOD/WOODFLOOR007A_-3616_-2976_1240
material "maps/rp_medievalrp_v2/wood/woodfloor008a_5504_-4352_328" not found.
Material not found!: MAPS/RP_MEDIEVALRP_V2/WOOD/WOODFLOOR008A_5504_-4352_328
Could not locate 'GameData' key in c:\program files (x86)\steam\steamapps\common\half-life 2\hl2\gameinfo.txt
Patching WVT material: maps/gm_laubuild_d/nature/blenddirtgrass006a_wvt_patch
Patching WVT material: maps/gm_laubuild_d/nature/blenddirtgrass001a_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...
Merged 930 detail faces...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (3)
writing C:\Users\RD\Desktop\Mapping\CODE\gm_laubuild_d.prt...Building visibility clusters...
done (0)

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 -25.2 26.3)
Leaf 0 contents: 
Leaf 1 contents: CONTENTS_SOLID 
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
Candidate brush IDs: Brush 59637: 

WARNING: node without a volume
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_wasteland02*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_wasteland02*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
WARNING: Map using power 4 displacements, terrain physics cannot be compressed, map will need additional memory and CPU.
done (1) (5586325 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Water found with no water_lod_control entity, creating a default one.
Compacting texture/material tables...
Reduced 7867 texinfos to 4884
Reduced 242 texdatas to 210 (9860 bytes to 8774)
Writing C:\Users\RD\Desktop\Mapping\CODE\gm_laubuild_d.bsp
10 seconds elapsed

** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\bin\vvis.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\hl2" -fast "C:\Users\RD\Desktop\Mapping\CODE\gm_laubuild_d"

Valve Software - vvis.exe (May 15 2014)
fastvis = true
4 threads
reading c:\users\rd\desktop\mapping\code\gm_laubuild_d.bsp
reading c:\users\rd\desktop\mapping\code\gm_laubuild_d.prt
8405 portalclusters
24549 numportals
BasePortalVis:       0...1...2...3...4...5...6...7...8...9...10 (23)
Optimized: 3384310 visible clusters (6.32%)
Total clusters visible: 53509006
Average clusters visible: 6366
Building PAS...
Average clusters audible: 8320
visdatasize:16677404  compressed from 17751360
writing c:\users\rd\desktop\mapping\code\gm_laubuild_d.bsp
37 seconds elapsed

** Executing...
** Command: Copy File
** Parameters: "C:\Users\RD\Desktop\Mapping\CODE\gm_laubuild_d.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\hl2\maps\gm_laubuild_d.bsp"


** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\hl2.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Half-Life 2\hl2" sv_cheats 1 +map "gm_laubuild_d" -steam


Would need to see your vmf or some shit, can’t tell much more with this

You seem to be running VVIS in -fast mode. Did you do expert compile or standard? Because of that, your map can be really glitchy. Try executing VVIS in normal, and see if the problem persists.

When this has happened to me before it’s usually been this type of error:

FindPortalSide: Couldn’t find a good match for which brush to assign to a portal near (0.0 -25.2 26.3)
Leaf 0 contents:
Leaf 1 contents: CONTENTS_SOLID
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs: Brush 59637:

This usually means there’s either a leak, if not change any brushes nearby to the coordinates (0.0 -25.2 26.3) to entity or entities to brush.