Water Issue

Guys I am having an issue with a prop and particles that I hope you can help me with.

I have a custom-made swimming pool prop with a water feature that has running water coming down it - the water is a particle and setup in Hammer.

In Half Life 2 Episode 2, the design I have works as planned:

In Garry’s Mod, there is some weird issue and the water doesn’t show in parts where the prop is behind it:

[THUMB]https://i.imgur.com/yVXVWqz.jpg

It’s worth noting that this issue happens on other maps in Garry’s Mod, like a bespoke-built box for testing. However it does not happen with props from Half Life 2 Episode 2, so it must be some sort of model issue.

Can anyone lend some assistance? I’m at my witts-end.

So does the particle effect have any refract properties or anything along those lines?

Also the particles are drawn but is drawn behind objects?

I’m quite new to using particles, so my knowledge is limited. I’ve had a look at the properties and I can’t see anything about refract.

Also not too sure what you mean by your second question, sorry.

[editline]10th September 2017[/editline]

This video shows it working with Standard Half Life 2 Episode 2 props: https://www.dropbox.com/s/5u03cipvcawoyj9/2017-09-10_14-26-15.mp4?dl=0

Does the particles go transparent against all nearby surfaces (ie. Brush based wall) or just against the rock model?

My thinking is if the particle’s vmf has $depthblend or a set fadedist in it, it could be causing issues against all nearby surfaces. The fix would be just to // out the depthblend and test.

It could also possibly be simpler then that- perhaps the particle uses $transparent and for whatever reason so does the rock that could create plane issues causing the rock to appear “above” the water particle system.

The rock and the pool are all one model. The particles work against everything else just fine; other Half Life 2 Episode 2 props, brush-based walls, other props made by the same guy that made the swimming pool, etc.

[editline]10th September 2017[/editline]

Also just confirmed with the creator of the model that the rock does not use $transparency, however the water texture for the particle does.

[editline]10th September 2017[/editline]

I decided to change the prop to prop_dynamic and see if that made any difference.

It didn’t, but it at least allowed me to show you a more detailed video of how the issue works: https://www.dropbox.com/s/ef7vbiziy6qhtga/2017-09-10_16-43-20.mp4?dl=0

[editline]10th September 2017[/editline]

I tried removing $transparency from the VMT of the particle’s water material, it didn’t resolve the issue.

I’m on my phone, didn’t mean to rate you dumb! Sorry!
You were very thorough, I don’t think it can be a transparency issue.
My thinking is it must be a depth setting or a fadedist setting in the particle’s vmf. Can you check? / Post vmf ?

Haha, no problem.

This is the VMF of the material the particle is using:


UnlitGeneric
{
$translucent 1
$basetexture "WaterSource/particles/Waterfall"
$vertexcolor 1
$vertexalpha 1
}


[editline]10th September 2017[/editline]

Also I have noticed that the particle is appearing / dissapearing depending on where you’re looking.

Video: https://www.dropbox.com/s/epsja5idxgnv93f/2017-09-10_17-04-15.mp4?dl=0

Well, this sucks. The vmt is fine.

Only other thing I can think of is perhaps a setting in the particle system it’s self causing the particles to disappear before being off screen entirely…?
Hell, it’s a shot in the dark, but perhaps it is your screen resolution and how maybe Gmod handles it?

Edit
Hopefully the texture can support it but maybe try replacing $transparent with $additive?

Just tested in a smaller resolution and aspect and the same issue.

It’s really damn frustrating because it’s such an important feature.

Congrats on 2,000 posts.
I totally understand the frustration. This seems familiar, I feel like I have ran into this or something similar to this before. I will keep thinking- I have a long shift at work and nothing better to do.

If you are still having issues next time I am by my computer I’ll see if I can do some testing.

I tried “$additive 1” on the particle’s water texture, hopefully that’s correct.

Sadly didn’t change anything.

Thank’s so much for your help, it’s really appreciated!

[editline]10th September 2017[/editline]

Got the modeler to make a random 300 x 300 block out of the texture which is used on the pool and dev texture, it worked: