We couldn't open that zip file.

I’m trying to upload a map. Will not accept my zip (which I repacked to make sure multiple times). I checked directories, everything looks fine. I can upload to gmod.org, however toybox refuses to work.

Is the issue resolved yet? If not, I have some tips.

  1. Make sure the Zip is layed out absolutely right (obvious I know)
  2. If your using Winrar or of the likes make sure compression is set to normal
  3. Check that you haven’t got any of the restricted directories (Not sure which but my brother had problems uploading an entity with the “sound/vo” directory)

If you still haven’t resolved it, post a directory / file list on here so we can all have a look.

Hope this helps!

Hello. I have exactly the same problem. At first I thought you can not pour large zip archives, but was not flooded at all no. After reading forum understand what often happens? Because of what so often happens when I fix it?

P.S. I am Russian and therefore apologize for my English:)

Is everyone all right once all the silence? Can somebody try to upload my zip file on the toybox? It is not clear at all how it works: (upload the folder with the models that weighs 20-25 MB and the error “We couldn’t open that zip file.” If you upload 1-2 model, the loads through time. I tried to get his map which weighs 65 MB and the same thing: (

From here you can download sound.zip http://dump.ru/file/5277003

P.S. Thank you in advance who will be able to explain what had happened. And I apologize for my English because I myself am Russian:)

I’m getting this error too now. I just want to upload my map!

Yes, I’m uploading a ZIP.
Yes, I’m using ‘normal’ compression.
Yes, my internet is fine.

How big is the zip file?

7.93 Mb. I’ve had no trouble with map files 3 times as large.

Maybe list the files it contains?

I’m trying to upload models for my SWEPs and I’m getting the same errors.

I’m also having trouble uploading an 8 MB zip file with just a .bsp in a /maps/ folder. I had to upload all content separately in multiple zips of 1 MB for it to work. I know uploading bigger files used to be possible, because I see 21 MB map files in toybox.

Alright I just tried it again, looks like it’s not taking uploads over 1 MB. I tried splitting my files up by seperating the models materials and sounds. The sounds came out to about 800kb the models were about 2mb and the materials were split into three zips each about 4/5mb. Toybox gave me the “we couldn’t open” error for everything but the sounds. Please fix this, I’d keep splitting but most of the materials come out to over 1mb compressed.

To who asked above, the only file in the zip is maps/dearesther.bsp

my zip file is around 34 MB if I remember correctly. its got a materials, a models, and a maps subdirectory.

You should pack your models and materials in the .bsp. I tried uploading everything separately to circumvent the size limitation, but everything shows up as errors in my map. (And yes, the models and materials do download when you install my map.)

It’s been two days, still getting these errors with any uploads over 1 megabyte. I really need to get this fixed most of the textures I want to upload are over 1mb compressed.

Getting this error too.

I guess I’m just going to have to use placeholder textures.

I’ll poke garry on GTalk tomorrow.

OK I made some changes - let me know if this is fixed now.

I tried to download the file with the textures of 23 MB and now everything is fine.

There is a desire on the ToyBox:) Downloading such material, if you suddenly have to remove a complete folder and all its contents, you have to delete one file. Can I do that it were possible to delete the entire folder?

I apologize for my English, but I hope it is clear wrote:)