Weapon animations not completing/working

I am completely at a loss here. I am trying to install the CS:GO knifes SWEP’s on my Deathrun server.

Now my server has had a problem for quite a while now with glowsticks, the viewmodel animation doesn’t play it sort of starts for a milisecond and then stops, Then when the glowstick ent is released it just floats in mid air.
This wasn’t much of an issue with the glowsticks but now that i am adding the cs:go weapons with the infamous weapon inspecting and such it is a massive problem.
I have tried numerous things such as:

  • Removing all addons except for the weapons and ulx to spawn them (They don’t work and when spawned just float in the air)
  • Changing gamemode to sandbox (same glitch as above)
  • I put the addon on another 3 gmod servers I host and they had the exact same issue.

The thing is I have Spy’s sleek weapon base on my server and the animations for the CS:S guns and such work absolutely fine.

When I put the addon into my addons folder and launch a multiplayer server they work completely fine.

The only possible thing that I think it could be is the server because it is Linux, It works fine on my windows computer.
But the weird thing is that some weapons such as the CS:S weapons work fine on the server, Has anyone heard of this kind of glitch before?

Thanks in advance.

All of the current CS:GO weapons are extremely buggy and I don’t recommend using them.

Your server is missing the models.

I have the workshop packs in the server collection and they are on the server though?

EDIT: That fixed it, I actually had a thought about this last night after I wen’t to bed but thought nah because the content was on the server from the workshop, My DarkRP server has FAS:2 weapons and they are just installed with the workshop file on the server and it is working fine, Anyway the issue has been resolved thank’s for your help.