Weird disconnects AFTER loading into server since last patch...

Since the last hotfix (rubberbanding i believe, might also be coincidental) i get the weirdest issue… i start up rust. I connect to the server, then it loads up and after i entered the game about 1/10th of a second later i get the disconnected: timed out message. After that i cannot connect to the server at all anymore for a couple of mintues before i can do it again and potentially disconnect immediately after it finished loading. It’s especially a frustrating issue if my graphicsdriver crashed in mid fight and i can’t connect back for half an hour / hour.

Video: https://www.youtube.com/watch?v=r8rleLEItQo&feature=youtu.be

It’s not on every server but nobody on the server has that problem otherwise it seems. They run anti-cheat, automatic vac bans and this automatic low ping kick script.

I’m pretty sure it’s not the anti cheat, i never had a vac ban and my ping to the server is in the low 20’s all the time (it gives you 3 warnings before it kicks, which take about 1 - 2 minutes, and Serveradmin confirms that my ping is excellent with no hiccups). I cannot make sense of this as i’m also having one of the fastest loading times of all people in my group… Does someone have a pointer as to what this might be ?

Things tried so far:

  1. Verified Files

  2. Started up with DX9

  3. Console only shows that error “Timed out - Returning to main menu”.

Specs:

Operating System: Windows 10 Pro 64-bit (10.0, Build 10240) (10240.th1.150807-2049)
Language: German (Regional Setting: German)
System Manufacturer: ASUS
System Model: All Series
BIOS: Default System BIOS
Processor: Intel® Core™ i7-4790K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
Memory: 16384MB RAM
Available OS Memory: 16326MB RAM
Page File: 5554MB used, 27156MB available
Windows Dir: C:\WINDOWS
DirectX Version: 12
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Not Available
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.10240.16384 64bit Unicode

Card name: NVIDIA GeForce GTX 780 Ti

Noone ? not even a guess ? :frowning:

Also tried to disable the firewall… doesnt help at all either.