Weird EP2 to Gmod problems

In my map, I have a very odd problem:

For most of the production time, I used EP2 to test my map to make sure it works. And everything did (aside from some texture overlaps)

But when I tried it on Gmod, I got weapons that refused to stay upright (when before they did) and this:

http://img683.imageshack.us/img683/9046/gmweaponstest0001.jpg http://img683.imageshack.us/img683/gmweaponstest0001.jpg/1/w1280.png

Exactly what causes this? And how can I fix it?

Also, I can I make a object “immune” against the physgun? Seems I can move around models with it that shouldn’t be picked up.

Any help on this would be great.

If the model can’t be prop_static I guess you could put an invisible brush around it to prevent physgunning

[editline]03:19AM[/editline]

What

[editline]03:20AM[/editline]

The wireframe texture thing means you don’t have that texture in-game so you should make sure that Ep2 is mounted in Gmod

[editline]03:21AM[/editline]

goddamn i am drink

Here’s the problem: EP2 IS mounted.

And for the gun problem, it’s apparent I didn’t explain very clearly. Here’s a pic:

http://img6.imageshack.us/img6/3240/gmweaponstest0002.jpg

Check the disable motion flag in the objects’ properties

For the weapons and the dynamic objects, there isn’t such a option. Also, it doesn’t work (can still pick them up).

On another note, I solved the water problem. Apparently, I forgot it was using the construct water texture (and it isn’t in the directory by default) so I added it in and now it works.

You could parent the guns to a non-moving object I suppose

In my knowledge there is a “start constrained” flag in weapons.

on a smaller side-note, make all the faces of your water brush (except the top face) tools/toolsnodraw.

Also, don’t use a water texture on all sides of a water brush, use nodraw on all then water on the top.

[editline]08:36PM[/editline]

Broke my auto-merge! :bang:

[editline]08:37PM[/editline]

AND NINJA’D ME :bang::bang::bang:

:smug:

Yeah, I forgot about that. It’s been fixed.

I already had that flag checked. It works for everything that isn’t the physgun.

Isn’t there some way to make them act like static objects while still retaining their normal properties?