Weird-ish texture on my worldmodel

Hello there.

I have a single problem that I can’t figure it out thus my problem remains unsolved but if any of you know, then I will be glad to appreciate your feedbacks/supports.

So, once I tried to rig and compile my model to work on Garry’s Mod, it happens like this:

http://puu.sh/jSXRO/7f8a38f4cb.jpg

http://puu.sh/jSXU7/b5324f89c5.jpg

I don’t know why it happens like that but zooming in does reflect the model to the original texture (see 2nd screenshot).
If any of you need my QC code, it’s here:

Or anything else, let me know on the comments below.

And like said above, I appreciate any feedbacks I receive.

$cdmaterials is listed twice in the QC, remove $cdmaterials “” under $cdmaterials “models\equipments” and see if that changes anything.

Same result as before. Any other ideas that you can share with?

keep it that looks cool

Ah, I found a solution how I fixed it.

I just forgot to tick the checkbox to add Mipmap('s) to it once I imported my texture and applied it with VTFEdit. I am dumb and didn’t noticed that.
Thanks anyway for helping.