Weird Issue

Does anyone know what this is and how to fix it?

Drivers updated
Games re-installed
Steam re-installed
Video settings at recommended

I would appreciate any help I can have identifying and solving this problem

System Specs?

http://img843.imageshack.us/img843/7470/specs1.png

http://img691.imageshack.us/img691/6954/specs2.png

Hi, I’m having the same issue. Thought it would be best to post here instead of making a new thread.

Specs copied from Speccy

Operating System
MS Windows Vista Home Premium 64-bit SP1
CPU
Intel Pentium E5300 @ 2.60GHz 36 °C
Wolfdale 45nm Technology
RAM
4.0GB Dual-Channel DDR2 @ 399MHz (6-6-6-18)
Motherboard
PEGATRON CORPORATION Benicia (CPU 1)
Graphics
HP 2009 @ 1600x900
Intel® G33/G31 Express Chipset Family
Hard Drives
625GB Western Digital WDC WD6400AAKS-65A7B2 (RAID) 30 °C
Optical Drives
hp DVD-RAM GH40L
Audio
Realtek High Definition Audio

It seems this isn’t just Garry’s mod, I am getting this problem in counterstrike source as well.

Okay, I may know what your problem is. You have Intel Video Chipsets. These are not well known for their gaming capacity. Try adding -dxlevel 81 to the start up options.

I’m having the exact same problem, and have been ever since one of the patches apparently messed something up. I’ve tried cleaning GMod to no avail, and so turn to you folk for aid.

These are my specs, if Xfire is to be believed.

Manufacturer: Compaq-Presario
Processor: Intel® Core™2 Quad CPU Q8200 @ 2.33GHz (4 CPUs), ~2.3GHz
Memory: 4086MB RAM
Hard Drive: 484 GB
Video Card: Intel® G33/G31 Express Chipset Family
Monitor: Generic PnP Monitor
Sound Card: Speakers (Realtek High Definition Audio)
Speakers/Headphones:
Keyboard: USB Root Hub
Mouse: USB Root Hub
Mouse Surface:
Operating System: Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (6002.vistasp2_gdr.100608-0458)

Again, the problem is the Intel® G33/G31 Express Chipset Family. They do not work well with Graphics Intensive programs.

Okay, so what do you mean by “Try adding -dxlevel 81 to the start up options”?

Is that to do with GMod specifically or something else? Forgive my ignorance when it comes to technical matters.

Right-click on the Garry’s Mod game in Steam then go to Properties then there should be a “Set Launch Options…” option then add -dxlevel 81 to that

Hey, it worked! Thanks a bunch, comrade. I would’ve been completely lost without you.