Weird positioning problem with compiling

I’ve made some animations and I tried compiling them and it completely worked but the end result wasn’t perfect

Here is what I want

This is what I got

Here’s my QC File that I used


$ModelName "weapons\v_sten.mdl"

$BodyGroup "studio"
{
	studio "Element1.smd"
}
$BodyGroup "hands"
{
	studio "broke's css.smd"
}

$SurfaceProp "default"

$Contents "solid"

$CDMaterials "models\weapons\v_models\sten\"
$CDMaterials "models\weapons\v_models\hands\"

$CBox 0 0 0 0 0 0

$BBox -10.728 -13.886 -15.002 23.16 10.545 0.433

$Sequence "idle" {
	"anims\idle.smd"
	activity "idle" 1
	fadein 100
	fadeout 0.2
	fps 10
	loop
}

$Sequence "reload" {
	"anims\reload.smd"
	activity "reload" 1
	fadein 0.2
	fadeout 100
	snap
	fps 30
}


Btw I use blender to animate and crowbar to compile if you need to know

Looks to me like bad origin. Go back to Blender, open your project file, make sure the hands and the weapon are in the position they need, press N to bring up a right side context menu, scroll down until you find Cursor location and set it to 0 0 0, which is the grid center. Then select everything in Object mode, and set origin to 3D cursor. This should fix the problem