Weird rubberbanding issue in rust

So, I’ve posted this is the rust discussion section in Rust, but then I realized how fucking stupid that is. So I’ll try my luck here, because I think this is where the devs read issues like this. Anyway, I don’t really know how to explain this issue, so I’ll post a video up.
[video=youtube_share;WOprVw8IC3Q]http://www.youtube.com/watch?v=WOprVw8IC3Q&feature=youtu.be[/video]

This is very prominent on the more busy servers. It’s just a side effect of network lag, either on your end or the server is too busy.

I don’t think so, this has never happened before, it’s only been happening recently.

This has been the issue both for me and many other players while playing Rust. Not sure why it hasn’t happened to you before.

Do a search for “rubberbanding” before posting next time. It’s been happening for several months.

Jeez chill out, I didn’t mean that this was a new issue surfacing for everyone, what I meant to say was that it hasn’t happened TO ME before, and it’s been persistent for the last few days. No matter when I log onto Rust, whether the server traffic is high or low, I get this issue, and my ping is normal as well, it’s 30-50 on the servers I go on. If there is a client issue causing this, are there anyways to fix this? It’s pretty much ruined Rust for me, as what you see in the video, is how it is on every server I connect to.

Get better internet?

That won’t help on heavy servers like the official ones. My Internet is perfectly fine and I had issues on those servers.

Then there is a problem with the server box, not with rust itself

This happened to me a few weeks back. My internet is very fast but I was getting rubberbanding no matter what server I played on. I waited a day and it kept doing the same thing. The console was spamming timing errors. I googled it and saw that Garry was looking into it and it seemed to happen on overclocked machines. I don’t overclock but I remembered The last time I booted up I got a bios message saying over clocking failed. I rebooted and made extra sure over clock was turned off. When I booted back up everything was working fine. I’m not really sure if I fixed a bios setting or just the reboot cleared things up, but it was definitely computer related.

Incorrect. It is the network code/engine that needs to be patched. It is a desync issue.

Is it like this: http://forum.facepunch.com/showthread.php?t=1346063
Or like this: http://forum.facepunch.com/showthread.php?t=1373779
Or both? You could follow the instructions in both threads to sort things out.