Weird SRCDS Error

When I have started up my SRCDS server and upon joining it, I get this:


Couldn't include file 'includes\modules\glon.lua' (File not found) (@gamemodes/*Gamemodename*/gamemode/cl_init.lua (line 5))

[ERROR] gamemodes/*Gamemodename*/gamemode/cl_init.lua:5: Module not found!
  1. require - [C]:-1
   2. unknown - gamemodes/*Gamemodename*/gamemode/cl_init.lua:5
    3. DeriveGamemode - [C]:-1
     4. unknown - gamemodes/*Gamemodename*/gamemode/cl_init.lua:8



The thing is, I have the said module inside “Includes\modules”
I’ve also tried converting the code to json, I still get the module problem. (And I also have Json in Modules)

All help appreciated, thanks for your time

GLON was removed in GM13. Use JSON or vON instead – preferably vON, because JSON has a habit of mangling tables and isn’t too careful about preserving long integers.

vON: See http://www.facepunch.com/showthread.php?t=1194008
JSON: replace glon.encode with util.TableToJSON and glon.decode with util.JSONToTable.

also dont forget to remove
require(“glon”);

it doesn’t if your code doesn’t use glon it will still try to load it if you require it.

Thanks alot, will try it out.