Weird Water Glitch

Ok so I just started on a map and blah blah blah and I added a pond blah blah blah and when I tested it out the water had this image on it. (If you have played Half Life 2: Lost Coast then its the beach at the beginning) I have tried changing the water type and I have even tried remaking the water. But still it has the picture on it. Anyone know how to fix it?

link to the picture here
http://s841.photobucket.com/albums/zz333/Dragonscreed96/Mapping/?action=view&current=rp_rockquarry0003.jpg#!oZZ1QQcurrentZZhttp%3A%2F%2Fs841.photobucket.com%2Falbums%2Fzz333%2FDragonscreed96%2FMapping%2F%3Faction%3Dview%26current%3Drp_rockquarry0001.jpg%26

did you add the water lod control?

Yes I did the water itself is fine its just I cant get rid of the picture on the surface of the water.

You have expensive water on more than one level.

Use a diffrent water texture?

[editline]11:48PM[/editline]

Or that 0_0

I HAVE tried a different texture as I have said.

And Whats expensive water?

Water that reflects in real time.

So… am I using the wrong texture?

Take a picture in hammer of your water. If it leads and ends anywhere.

I really dont know what you mean by “Leads or Ends Anywhere”

:bang:

How many brushes of water do you have.

Just one

On the brush. Is only the top face a water texture and the other sides are nodraw?

Only the top has a water texture applied to it and yes the sides are nodraw

Does the water happen to lead to a 3D skybox?
What graphics card do you have?
Is your water quality set to high?
Did you place cubemaps and build them?

Ok ok bombarded with questions here so…

Question Numbah 1: I DO have a 3D skybox but it stays out of it
Question Numbah 2: I have a NVIDIA GeForce 9500 GT
Question Numbah 3: Yes
Question Numbah 4: I dont know what a cubemap is :o

Hey you have the same card as me :v:

A cubemap is an entity.

If you can see the 3D skybox from the water. As in you want it to reflect the 3D skybox. It wont work.

So how do I fix it :stuck_out_tongue:

Did you try building cubemaps?

You essentially need to build an entity that it will reflect other than the skybox. it doesn’t need to be visible.