What is going on!?!?!?!?!?!?!?!?!?

Every time I try to spawn ANYTHING with thrusters on it using the advanced duplicator, I get an ERROR saying “Cannot make Gmod_thruster!” When I enter the developers console I get this line of code: (This specific one from Klayking’s go-kart)

AdvDupeERROR: CreateEntity failed to make “gmod_thruster”, Error: includes\util.lua:71: bad argument #1 to ‘PrecacheSound’ (string expected, got boolean)
AdvDupe: Sending this ErrorMsg to Player [1][mrfood]
AdvDupe-ERROR: “Failed to make “gmod_thruster””
AdvDupeERROR:Created Entity Bad! Class: gmod_thruster Ent: 122
AdvDupeERROR: CreateEntity failed to make “gmod_thruster”, Error: includes\util.lua:71: bad argument #1 to ‘PrecacheSound’ (string expected, got boolean)
AdvDupe: Sending this ErrorMsg to Player [1][user]
AdvDupe-ERROR: “Failed to make “gmod_thruster””
AdvDupeERROR:Created Entity Bad! Class: gmod_thruster Ent: 124
AdvDupeERROR: CreateEntity failed to make “gmod_thruster”, Error: includes\util.lua:71: bad argument #1 to ‘PrecacheSound’ (string expected, got boolean)
AdvDupe: Sending this ErrorMsg to Player [1][user]
AdvDupe-ERROR: “Failed to make “gmod_thruster””
AdvDupeERROR:Created Entity Bad! Class: gmod_thruster Ent: 121
AdvDupeERROR: CreateEntity failed to make “gmod_thruster”, Error: includes\util.lua:71: bad argument #1 to ‘PrecacheSound’ (string expected, got boolean)
AdvDupe: Sending this ErrorMsg to Player [1][user]
AdvDupe-ERROR: “Failed to make “gmod_thruster””
AdvDupeERROR:Created Entity Bad! Class: gmod_thruster Ent: 123
AdvDupeERROR: Problem with = Weld Constraint. Could not find Ent: 123
AdvDupeERROR:Could not make constraint type: Weld
AdvDupeERROR: Problem with = Weld Constraint. Could not find Ent: 124
AdvDupeERROR:Could not make constraint type: Weld
AdvDupeERROR: Problem with = Weld Constraint. Could not find Ent: 122
AdvDupeERROR:Could not make constraint type: Weld
AdvDupeERROR: Problem with = Weld Constraint. Could not find Ent: 121
AdvDupeERROR:Could not make constraint type: Weld

What is going on!?!?!?

EDIT: Thanks for the Help everyone! no Further help is needed! Although I could use some help with this http://www.facepunch.com/showthread.php?t=884833.

The Garry’s Mod update means all old thrusters don’t work. Not enough information specified in dupe file AKA: Adv Dupe doesn’t specify the new sound option, so it just errors out.

Gotta love those updates. I hate when my old addons stop working and no one updates them…

Happened to me too. :frowning: I had a bunch of cool stuff with thrusters and now it doesn’t work.