What is wrong with my serve?

Can anyone help?

also i spawn with no weapons at all, nothing

also getting this :
Lua Error: [ERROR] gamemodes/darkrp/gamemode/modules/money/sv_money.lua:7: attempt to perform arithmetic on a nil value 1. addMoney - gamemodes/darkrp/gamemode/modules/money/sv_money.lua:7 2. callback - gamemodes/darkrp/gamemode/modules/money/sv_money.lua:33 3. retrieveSalary - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:278 4. payDay - gamemodes/darkrp/gamemode/modules/money/sv_money.lua:25 5. unknown - gamemodes/darkrp/gamemode/modules/jobs/sv_jobs.lua:160

I havent touched base darkrp, so idk whats that

Reinstall DarkRP completely with no addons or modifications.

i had to transfer 5k files from just the addons folder, is that bad?

Not necessarily as long as you don’t hit the limit (think it’s around 8000)

I’ve had to do many darkrp installs because i though i had passed the file limit which i though was 2.5k, i also have a bit of addons, does that matter too on why im getting base darkrp errors?

Maybe, but you would probably be getting way more errors if you had hit the limit.

Okay so base darkrp is brand new, what should i do now? I dont wanna get the same error again.

Do you still have the error after the reinstall?

No, but i havent installed all the addons i had before.

Add them in chunks instead of all at once to narrow down what’s causing the error.

Okay ill be awhile, im just fixing my darkrpmodification because there are errors of commands

[editline]28th February 2015[/editline]

So far everything looks good, but one question, i try to buy an entity and all it does is type the buy command out, but it donest buy,
AddEntity(“Flash Bang”, {
ent = “weapon_concussion_nade”,
model = “models/weapons/w_grenade.mdl”,
price = 1500,
max = 2,
cmd = “flash”,
})

bump

Try this instead.



DarkRP.createEntity("Flash Bang", {
	ent = "weapon_concussion_nade",
	model = "models/props_lab/reciever01a.mdl",
	price = 1500,
	max = 2,
	cmd = "flash"
})


Nope that didnt work, it just takes my money and donest give me anything

Double check that, that is the right ent. And the model is the right model.

oh guess it worked, but it was invisible so i couldn’t see it, can i change the model back to looking like a grenade in the f4 menu? and when dropped?