What is wrong with these textures and weird arse lines.

Thats all i can say, the road texture has gone missing etc. Feel free to ask questions also no errors in compile log.

this happened after i added more custom textures to the custom textures folder.

Bump

Post the vmt contents of the road textures you’re using.

https://drive.google.com/file/d/0B8FTcNfQWq2ZRzVERWJlUUdSVFU/view?usp=sharing

[editline]20th January 2016[/editline]

All of the materials custom made for my map.

I looked at the textures and had no problem with them in game.

http://i.imgur.com/b2WLkJP.jpg[/t]

In the editor they showed up odd (corrupted?), which I think has something to do with the mipmaps and/or how you saved the textures.
[t]http://i.imgur.com/vQpOAeN.jpg

It might be attributed to your problem you pictured, but I failed to replicate the issue in my compile.

Do we know what could cause it like, do them lines represent something of an error seen before, is their any infomation I can tell you?

I think I recall getting that error way back when I first started making textures years ago. I cannot remember how I fixed it though.

Its showing a wireframe instead of the black and purple checkers- my first thought and assumption would be an issue with the brush, not the texture. You could try remaking the brush that the texture is on and seeing if it continues with a new brush.

Another thing I noticed when looking at the VMT is that you are lacking surface properties for all the textures.


"LightmappedGeneric"
{
			"$basetexture" "rp_local\road_asphalt_blank"
}

You could try adding that like so:


"LightmappedGeneric"
{
	"$basetexture" "rp_local\road_asphalt_blank"
	"$surfaceprop" "Concrete"
}

Other then that, I’d say try reexporting the textures from whichever program you are using. Try saving the textures as uncompressed BGR888 and with mipmaps enabled.

I am really scratching the bottom of the barrel, but I’d say its worth a shot on any of these things.

Ok I’ll have a look, they were working before, that’s what I dint get.

Rendering wireframe instead of the material could also mean the shader did not load a wrong shader is supplied in the .vmt file.

The $surfaceprop would have no effect on it, many default materials do not have it.

What you also should do is replace backslashes ( \ ) with forward slashes ( / ) in your path names.

Ok so what is causing the lines, and how do i fix them.

Good eye, I hadn’t even noticed it was all backslashed.

What Robotboy said to do.
Definitely try changing your backslashes to forward slashes. More then likely its messing with how the vmt is finding its path to the vtf.

Ok thank ye. I just thought he meant it being neater, not that it could be causing the problem