What the fuck is this error?: "Assert Failure - No NODEINDEXSTR Property"

I’ve been trying to export a Dawn of War 2 head to SMD for at least two fucking hours now using Santos Tools, and every single time I try to export it THIS motherfucking error comes up and the exported SMD is corrupt or chunks of it are missing.

Every time. Even if I export it to a different format and reimport it. What the fuck is going on? I’m at the end of my tether.

post the max file?

Here you go.

There’s no bones in this version because it’s literally just the head for reference. The body has absolutely no issues exporting whatsoever.

works for me lol

http://puu.sh/8xBze.png

What you need to take into consideration is the string name of the mesh maybe thats whats causing the issue I renamed it to something simple like head and head_base from “merged material-[deathkorps_lord_comissar,relic.material.commissar_armour_head]”
to be honest thats one long ass name.

also I’m guessing your using this for the material?

http://puu.sh/8xBFb.png

not sure how well the SMD exporter plays if the material assigned to the mesh uses that, i applied a new material to it.

-EDIT-
Actually I was right

http://puu.sh/8xBOt.png

fix that material it uses and it should be fine

https://dl.dropboxusercontent.com/u/10798900/DUMPBOX/fixed.max

Well fuck-a-doodle-doo. Thank you for fixing it.

Checked it now. Didn’t work, it still disappears on export just with no errors this time.

[editline]3rd May 2014[/editline]

It looks like my SMD exporter is outdated, too. What’s the one you’re using?

Are you using the SMD exporter from wunderboy.org? This one has to work properly.

I’m using cannonfodder’s. I’ll try Wunderboy’s.

[editline]4th May 2014[/editline]

Yup, wunderboy’s worked.

There we go.

Problem solved :slight_smile: