When I compile, my entire map is fullbright, how can I fix this?

I’ve tried turning off mat_fullbright once in game, that didn’t work. I’ve tried looking for any leaks, there were none. I’ve optimized my level as much as I could. I don’t know what’s wrong.

** Executing…
** Command: “D:\Steam\SteamApps\common\half-life 2\bin\vbsp.exe”
** Parameters: -game “D:\Steam\SteamApps\common\half-life 2\hl2” “C:\Users-----\Desktop\custom.vmf”

Valve Software - vbsp.exe (May 15 2014)
4 threads
materialPath: D:\Steam\SteamApps\common\half-life 2\hl2\materials
Loading C:\Users-----\Desktop\custom.vmf
Could not locate ‘GameData’ key in d:\steam\steamapps\common\half-life 2\hl2\gameinfo.txt
Patching WVT material: maps/custom/nature/blendsandsand008a_wvt_patch
Patching WVT material: maps/custom/nature/blendgrassgravel001a_wvt_patch
Patching WVT material: maps/custom/dev/dev_blendmeasure_wvt_patch
fixing up env_cubemap materials on brush sides…
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
Processing areas…done (0)
Building Faces…done (0)
Chop Details…done (0)
Find Visible Detail Sides…
Merged 20 detail faces…done (0)
Merging details…done (0)
FixTjuncs…
PruneNodes…
WriteBSP…
done (0)
writing C:\Users-----\Desktop\custom.prt…Building visibility clusters…
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day02_05*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day02_05*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors…
Finding lightmap sample positions…
Displacement Alpha : 0…1…2…3…4…5…6…7…8…9…10
Building Physics collision data…
done (0) (14743 bytes)
Placing detail props : 0…1…2…3…4…5…6…7…8…9…10
Water found with no water_lod_control entity, creating a default one.
Compacting texture/material tables…
Reduced 57 texinfos to 30
Reduced 19 texdatas to 15 (535 bytes to 411)
Writing C:\Users-----\Desktop\custom.bsp
1 second elapsed

** Executing…
** Command: “D:\Steam\SteamApps\common\half-life 2\bin\vvis.exe”
** Parameters: -game “D:\Steam\SteamApps\common\half-life 2\hl2” “C:\Users-----\Desktop\custom”

Valve Software - vvis.exe (May 15 2014)
4 threads
reading c:\users-----\desktop\custom.bsp
reading c:\users-----\desktop\custom.prt
27 portalclusters
1265 numportals
BasePortalVis: 0…1…2…3…4…5…6…7…8…9…10 (0)
PortalFlow: 0…1…2…3…4…5…6…7…8…9…10 (2)
Optimized: 0 visible clusters (0.00%)
Total clusters visible: 623
Average clusters visible: 23
Building PAS…
Average clusters audible: 27
visdatasize:437 compressed from 432
writing c:\users-----\desktop\custom.bsp
2 seconds elapsed

** Executing…
** Command: “D:\Steam\SteamApps\common\half-life 2\bin\vrad.exe”
** Parameters: -game “D:\Steam\SteamApps\common\half-life 2\hl2” “C:\Users-----\Desktop\custom”

Valve Software - vrad.exe SSE (May 15 2014)

  Valve Radiosity Simulator     

4 threads
[Reading texlights from ‘lights.rad’]
[45 texlights parsed from ‘lights.rad’]

Loading c:\users-----\desktop\custom.bsp
Setting up ray-trace acceleration structure… Done (0.03 seconds)
11869 faces
41503248 square feet [5976467456.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
11869 patches before subdivision
546103 patches after subdivision
sun extent from map=0.000000
8 direct lights
BuildFacelights: 0…1…2…3…4…5…6…7…8…9…10 (33)
BuildVisLeafs: 0…1…2…3.
** Executing…
** Command: Copy File
** Parameters: “C:\Users-----\Desktop\custom.bsp” “D:\Steam\SteamApps\common\half-life 2\hl2\maps\custom.bsp”

** Executing…
** Command: “D:\Steam\SteamApps\common\half-life 2\hl2.exe”
** Parameters: -game “D:\Steam\SteamApps\common\half-life 2\hl2” +map “custom” -steam

This might be a stupid question, but there are lights in your level, right?

Of course.

vrad.exe appears to be terminating early. It must finish, or your map won’t have any lighting.

That’s odd, is there any reason to point out, why it’s doing that?

It looks like it’s having some sort of issue with the visleaves, as that’s when it’s terminating early. I’d suggest you start investigating there.

I managed to fix it, thankyou!

In honor of this comic, could you tell use how you fixed it?

Sure, all I had to do was put the lightmap scale of the non-important brushes to 256, and it worked!