When I Run a Map, Entities are missing.

So I have started using Source SDK for the first time, and it is mucho easier than the GECK, but I have ran into this problem, everytime I run the map, there are missing entities, and that really bugs, me, because I am trying to make a ice little map to see how good I am at the hammer for the first time. Can someone please provide a solution to have the entities apear int he map when I test it out?

How it looks in the Hammer:

How it looks in the game:

Why does it do this?
How can I fix it?

this is what is going on with my map if this help you to hel[ me

You have them set to the wrong prop type I would guess.

well how would I fix that then?

Check what prop type they are supposed to be in the model browser and choose the appropriate type.

In case you really need these entities to have physical or dynamic properties, type prop_dynamic_override or prop_physics_override
I’m doing the same on so many L4D2 props which mostly have static and dynamic properties.