When players try and physgun a prop they do not own it no collides it.

Whenever a player attempts to physgun a prop, regardless of if they own it or not, it becomes nocolided. The issue came up after the adding of VCmod, if you need anymore information just ask and I will supply it, thanks for taking the time to read this though.

any errors?

Is it no collided just to them, or to everything? It could be that the mod uses

Entity:SetOwner which it shouldn’t do.

Nope no errors.

It disables the collisions on it, when you use the c menu and look it shows as unchecked when someone tries to physgun it, and where would the Entity:SetOwner be located?

Then it’s some bad mod. You can check what’s doing it with this (untested):
[lua]local ENTITY = FindMetaTable(“Entity”)

local old_setcolgroup = ENTITY.SetCollisionGroup

function ENTITY:SetCollisionGroup(g, …)
old_setcolgroup(self, g, …)
if g == COLLISION_GROUP_WORLD then
print(tostring(self) … " - collisions being disabled!")
debug.Trace()
end
end[/lua]

This should show you in the server console what’s disabling the collisions.

how exactly should I run this?

By making a Lua file in autorun

that broke the server lol, but we figured out that it was something with our prop protection.

That kind of addons should normally always be the first place to look. Anyways if it’s solved then you should close this thread by marking it as solved.