When SRDCS is on; "Connection failed after 4 retries"

I know this may sound wrong to you, but I’m looking to host a server from my own PC with the same IP address. I’m not looking to put up a full-time dedicated server, just a 5-player password server that I can launch whenever I want to peacefully build with my friends. Right now I can launch the server and others are able to connect to it, but meanwhile I’m not only unable to join the server, but I can’t join other servers as well. The error I get is the typical “Connection failed after 4 retries”-one.

Anyone know a possible fix, in case there even exists one? The error comes with both firewall on and off, so that shouldn’t be the case.

Thanks.

Are you connecting via the public IP?

Yeah, I supposed. Should I try using my local IP through the console?

Nope, it doesn’t work even if I try to connect with the local IP. Any other ideas?

Hello Hell0,

did you try connection to your LAN IP or the local (127.0.0.1, localhost) one?
The 127.0.0.1 one should work -always-

What startup cmd-line and what config (pastebin) are you using?
Can you copy/paste the server log from startup?

Press Windows key+r type cmd press enter

then type


ipconfig /all

Scroll up intil you find a line as sutch

IPv4 Address. . . . . . . . . . . : locl.ip.adr.ess

now slap on the port your server is running on

lcl.ip.adr.ess:27015

for example
192.168.1.1:27015

NOW go in game and in console ON YOUR game type in this and press enter


connect 192.168.1.1:27015

you have to use your local ip address because you cant connect to a server hosted on your network using the external IP address

I also have a problem with my dedicated server. In my case others can join flawlessly, but I can’t join, not with my local ip or external ip. (connection failed after 4 retries)

Does anybody know what is wrong?

As previously mentioned in the thread, did you try the localhost IP 127.0.0.1?

That is, if you are hosting on the same computer.

I tried localhost, but I have solved the problem now. :slight_smile:

I used this wiki: http://maurits.tv/data/garrysmod/wiki/wiki.garrysmod.com/indexb076.html
But it’s outdated / doesn’t work.

They say to launch the server you need to use this code:


 srcds.exe -console -game garrysmod -port 27016 +map gm_construct +maxplayers 16 -ip 0.0.0.0 

But you have to use


 srcds.exe -console -game garrysmod +hostport 27016 +map gm_construct +maxplayers 16 +ip 0.0.0.0 

With the second code I could join my server flawlessly!