Why aren't my doorgroups working?

Title says it all, I have no clue why they arent working

In my doorgroups.lua the command written is “AddDoorGroup(“Government Officials only”, TEAM_GOVERNMENT)”

in my jobs.lua the job i want to be able to unlock the door is

"TEAM_GOVERNMENT = DarkRP.createJob(“Jail Guard”, {
color = Color(20, 0, 255, 255),
model = {“models/player/barney.mdl”},
description = [[Simply put, you sit in the jail and wait for inmates to arrive, you may then take them to the courtroom so they can appeal their arrest, or take a bribe to let them out of jail]],
weapons = {“unarrest_stick”, “stuntick”, “arrest_stick”, “door_ram”, “weapon_mac102”, “climb_swep2”},
command = “jailg”,
max = 2,
salary = 55,
admin = 0,
vote = false,
hasLicense = true,
candemote = true,
level = 8,
– CustomCheck
medic = false,
chief = false,
mayor = false,
hobo = false,
cook = false,
})
"

I don’t know what I did wrong?

The code seems to be fine (to me). Do you have Simplerr disabled?

no, idk how to do that

This has worked before i have no clue why it isn’t now

Okay, so to disable Simplerr all you have to do is write #NoSimplerr# in a comment.

So, for example, you would put #NoSimplerr# here:



--[[---------------------------------------------------------------------------
Door groups
---------------------------------------------------------------------------
The server owner can set certain doors as owned by a group of people, identified by their jobs.

#NoSimplerr#

HOW TO MAKE A DOOR GROUP:
AddDoorGroup("NAME OF THE GROUP HERE, you will see this when looking at a door", Team1, Team2, team3, team4, etc.)
---------------------------------------------------------------------------]]


And in the jobs.lua file:



--[[---------------------------------------------------------------------------
DarkRP custom jobs
---------------------------------------------------------------------------

#NoSimplerr#

This file contains your custom jobs.
This file should also contain jobs from DarkRP that you edited.

Note: If you want to edit a default DarkRP job, first disable it in darkrp_config/disabled_defaults.lua
	Once you've done that, copy and paste the job to this file and edit it.

The default jobs can be found here:
https://github.com/FPtje/DarkRP/blob/master/gamemode/config/jobrelated.lua8

For examples and explanation please visit this wiki page:
http://wiki.darkrp.com/index.php/DarkRP:CustomJobFields


Add jobs under the following line:
---------------------------------------------------------------------------]]


Try that, and then restart your server.

Still not working :frowning:

Try adding another job to your door group. (Just to test it)

soo, this is weird, it works for the second job but not the first?

[editline]26th March 2016[/editline]

For any reason could it be because i have multiple jobs on “TEAM_GOVERNMENT”?

The issue was because I had multiple jobs labeled “TEAM_GOVERNMENT”