Why is my vsync broken?

I’m having problems with games vsync because it obviously does not work.

Without vsync my pc is constantly overheating, capped out at 300fps
I’ve tried numerous ways attempting to solve this problem but not one has solved my issue.

Here is what I’m running;
OS Name Microsoft Windows 8.1 x64
Processor Intel® Core™ i7-4790K CPU @ 4.00GHz, 4000 Mhz, 4 Core(s), 8 Logical Processor(s)
GPU
DirectX version: 11.0
GPU processor: GeForce GTX 970
Driver version: 353.30
Direct3D API version: 11.2
Direct3D feature level: 11_1
CUDA Cores: 1664
Core clock: 1050 MHz
Memory data rate: 7010 MHz
Memory interface: 256-bit
Memory bandwidth: 224.32 GB/s
Total available graphics memory: 12263 MB
Dedicated video memory: 4096 MB GDDR5
System video memory: 0 MB
Shared system memory: 8167 MB
Video BIOS version: 84.04.1F.00.70

Here are the attempts I’ve tried to solve my issue;

  1. Forcing fps with Nvidia CP (Learned gmod overrides that)
  2. Using in-game advanced setting options (Nothing happens)
  3. Reinstalling gmod (No changes have occurred)
  4. Updating hardware BIOS/software/OS (Nothing happens)

Can someone please tell if my system is compatible with gmod?