Why is the game running incredibly bad for me?

Hi. I bought RUST couple of days ago since my friends play it and the first thing I notice is how bad it runs on my computer for some reason. I immidiately turn down all the graphics to minimum which I thought would solve the problem but unfortunately it didn’t. My buddies told me to type in the grass.on false command which reduced the lag a little bit but not entirely. I went to google and found some helpful things but I didn’t feel like always having to type in 10 lines of code in the command box every time I launch the game. There was also another thing that was mentioned, I was told to go to Rust’s properties in Steam and add some things in the Set Launch Option which reduced ALL the lag but instead made the sky look like you were high on shrooms. Please help me if you know how to solve my problem!

Computer specs:
NVIDIA GeForce GT 630M
8GB RAM
Intel Core i7-3610QM CPU @ 2.30GHz

Might be the game settings. Check out this tool I made http://forum.facepunch.com/showthread.php?t=1357804

thats crazy - its running fine for me?

Core2duo 3.16, 8gb ram, radeon hd 6870

old drivers??

If these specs are for a laptop, do you have NVidia optimus? because i had the same issue with a GTX 765M graphics card and i found out the game was only using my small Intel gpu.

,
I do have a laptop so I guess I’ll give Nvidia optimus a try, time to google what the hell that is :stuck_out_tongue:

[editline]2nd February 2014[/editline]

I re-installed my operative system a few days ago so all drivers are up to date.

If you can get into your NVidia graphics panel, go to 3d settings and the program settings tab, then find your rust.exe program to customize. If you have optimus you can select which graphics processor to run the game with. Forcing it to use my GeForce brought me up to a smooth 45-ish fps on full graphics. I will warn you that this made my CPU VERY HOT on the higher graphics settings.

630 is a low graphics card… that is prob the problem…

Try lowering the resolution that so far seems to have done the most for me when I am running in linux. Usually the 1280 one.

Try joining our survival server: net.connect 192.99.13.185:28047

We have a plugin that turns off major fps destroyers, just type /fps in game.

Otherwise try lowering your render scale & resolution

I would like to inform that Rust was using my Intel HD graphic 4000 instead of my NVIDIA GeForce GT 630M and therefore made me lag. After I switched graphic card everything worked fine!

Thanks to a lot for the fast answers, much appreciated!

Glad you got it figured out! My intel HD 4600 wasn’t doing too well either lol

You’re playing it on a laptop so… Make sure the cooling system work.