Why on earth won't FastDL downloads from my server stay downloaded?

Been trying to get a server running, but I’m struggling with the FastDL thing.

I get my servers for free from a mate, and use TCAdmin to manage it all. I’m using the panel’s built-in FastDL facility, and it works OK for the map.

Right now the mods I’ve got are Wire, a few STools, Drumdevil’s Props and a few player models (the Star Wars set and a couple of others). None of these are working.

This is my FastDL folder.

This is the game server: 178.32.149.41:27015

This is my resources.lua file:


local ClientResources = 0;
local function ProcessFolder ( Location )
for k, v in pairs(file.Find(Location .. '*')) do
if file.IsDir(Location .. v) then
ProcessFolder(Location .. v .. '/')
else
local OurLocation = string.gsub(Location .. v, '../addons/wire/', '')

if !string.find(Location, '.db') then
ClientResources = ClientResources + 1;
resource.AddFile(OurLocation);
end
end
end
end

 if !SinglePlayer() then
ProcessFolder('../maps/');
ProcessFolder('../addons/wire/');
ProcessFolder('../addons/');
ProcessFolder('../materials/drumdevils_props');
ProcessFolder('../materials/models');
ProcessFolder('../materials/maps');
ProcessFolder('../materials/VGUI');
ProcessFolder('../models/drumdevils_props');
ProcessFolder('../models/Batman');
ProcessFolder('../models/madjawa');
ProcessFolder('../models/player');
ProcessFolder('../lua/');
ProcessFolder('../settings/');

end

This is what i’m getting when I join the server:


Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - :0
Browser Message: Uncaught ReferenceError: SetFilesNeeded is not defined - :0
Browser Message: Uncaught ReferenceError: SetFilesTotal is not defined - :0
Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - :0
Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - :0
Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - :0
Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - :0
Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - :0
etc
etc

Any help getting this working would be awesome. Cheers.

Are you using ULX?