why won't this stuff work? (SB, LS, SBEP, RD,...)

So after a year or 3 i descided to dust off and fire up gmod again, felt like building some spaceships!

all the steam software has been through numerous formats which caused gmod to be quite glitchy. I couldn’t use adv dupe to place my spaceships (kept getting “stool not active” errors) so i had to reïnstall gmod. Not a problem, spend a couple of hours searching for the right mods again.
Seems they’re all outdated. Right now i’m running SB2 (and SB3), RD2, LS2,… etc.

First problem is that i can’t get my generators to work. I spawn some windgenerators, batteries and hook them all up to a resource node. That works just fine, it shows me that i’m producing energy.
Next i spawn some oxygen compressors and tanks, again hook them up to my resource node and this too works. The node updates itself and now shows that i have a shitton of energy and 0 oxygen.
I try to fire up my oxygen compressor and… nothing. It says 0 energy. Same goes for any “energy using” device i try to hook up. It’s been a very, very long time so i might be overlooking something but AFAIK that’s all i need to do, right?

As far as i can see the rest doest work. I can spawn premade models, make my own,…etc. I have only been trying since yesterday evening so I have by no means tested everything. I am running both SB2 and SB3 (SB3 being the only “version 3” software that i could actually download).

Here’s a complete list of addons i’m running:

  • wiremod
  • adv dupe
  • LS2 (extended)
  • RD2
  • SB2
  • SB3
  • SB3 content
  • SBEP

Then the second problem, seeing as everything i’m using is hopelessly outdated i searched for some LS3 SVN links, i did find them but none of them work.
I tried SnakesSVx’s links and those from a variety of other websites. (http://archive.snakesvx.net/index.php/module_Wiki2/title_Help_Info_SVN and https://sites.google.com/site/gmodsvnlinks/ to give some examples).

Whenever i try to download them they prompt me for a username and pw, this struck me as odd seeing that the sites mentioned (if they say anything about it) that it shouldn’t ask you for a username/pw.
I did try anon/anonsvn/anonymous in pretty much every possible configuration, which worked for all the other svn links, without succes.

Any help would be greatly appreciated :slight_smile:

If I’m correct, SBEP is no longer updated and most of it is broken.

that sucks :frowning:

are there alternatives? how about ls3 and all its sub components?

I never was into SBEP, so the only thing I know is that some really cool gamemode edits are being made in the gamemode section, a few subforums down from here.

Sorry that I wasn’t a big help, but I’m sure there are some nice guys down there that will give you links to anything that still works. Keep in mind though, when the gmod 13 updates officially comes out, everything with lua will break, so I’m sure someone will refix it for gmod 13 at some point in time.

well, i figured it indeed had something to do with the lua code. Every time i tried to spawn a generator in game it came up with a lua error “trying to compare a number with a table” or something like that.
This is the full error i get ingame: [lua\entities\base_rd3_entity\cl_init.lua:84] attempt to compare number with table

I could trace it back to this piece of code:


if HasOOO then
				local runmode = "UnKnown"
				if self:GetOOO() >= 0 and self:GetOOO() <= 2 then
					runmode = OOO[self:GetOOO()]
				end
				OverlayText = OverlayText .. "Mode: " .. runmode .."
"
			end

this part to be more precise: self:GetOOO() >= 0 and self:GetOOO() <= 2

If i can believe eclipse at least that this is line 84 (the error in game said line 84 so…)

I don’t know what’s wrong with it though, the function GetOOO returns a numer as far as i know:

return self:GetNetworkedInt(“OOO”) or 0

I haven’t been able to backtrack the “GetNetworkedInt” function though. I might just be overlooking it but then again i’m not at all knowledgable about lua. :\

Why are you using both SB3 and SB2? Use only SB2 for now, plus the creator of SB said he’s already working on porting SB into garry’s mod 13, so expect an updated version soon.

well, i fixed it :smiley:

The issues wasn’t in sb2 and sb3 being used at the same time, it was because rd2 conflicted with rd3 of which i didn’t know i had it.
Apparently my sb3 came with rd3. This caused some vital functions to be overwritten.

Now the generators still show “0/0 energy” but they work ^^

Also: it would be great to see an updated version of SB for gmod 13 :slight_smile: