Wich are the differences between a windows server and a linux server?

Hello.

Excuse me for any grammatical errors.

The title doesn’t perfectly explain my question, so before comment read all.
I don’t know why my script perfectly works on a windows server, but not on a linux server.

I know that in a linux server, I have to make all folders names in lower case, then the problem isn’t this.
In this my script I created a config file in lua/autorun, like this:



CF = {}
CF["config1"]
CF["config2"]
etc...


And in server side and client side, I used the config like this:



print("your first config is "..CF["config1"].."!")


In a windows server this script perfectly works, but in the linux server, when the script starts, the console gives me this error:



[ERROR] addons/myaddon/lua/autorun/server/myaddon.lua:2: attempt to index global 'CF' (a nil value)
  1. unknown - addons/myaddon/lua/autorun/server/myaddon.lua:2


Someone know which is the problem?
Thank you!

Beacouse on windows the config file loads before.
In Linux the config loads after.
Try adding that print to the hook Initialize.

nothing has changed…

[editline]29th July 2016[/editline]

Now I tried to add a 10 seconds timer, but nothing has changed, now the console gives the error 10 seconds after.

I think the server doesn’t load the config file, like if the filename is uppercase.

[editline]29th July 2016[/editline]

I fixed it.

I changed the name of the config file.
Another addon are using this name…
Thank you!