Windows 7 users

After the new Rust update I would get rust Launcher error install windows service pack 2 to run easyAntiCheat. guess what THERE IS NO WINDOWS SERVICE PACK 2 for Windows 7.

You sure it’s not “Microsoft .NET Framework 2.0 Service Pack 2” it is looking for?

Hi,

Sorry about this issue. It seems that if Steam is started in compatibility mode, EAC will falsely think the compatibility mode’s set OS version is the real OS version. This will be fixed shortly, still within today.

As a temporary fix, login first to Steam and then start the game from Steam\SteamApps\common\rust\Rust.exe, and check in the .exe’s properties that it is not set to be started in compatibility mode.