Windows Update Saver?

So I have Vista, and when playing gmod, I have the extremely annoying problem of Windows Update. Every 2nd Tuesday, it installs updates and (is supposed to) ask your permission before installing them. With gmod running, it doesn’t do anything; no noise, no focus stealer, no nothing. So, after working on something for 4 hours, and Windows Update restarts your computer, you’re pretty pissed!

Enough of the intro:
My request is that, every 2nd Tuesday of the month, a lua script comes up, and gmod autosaves every 10 (or other number) minutes. I’m not fluent in lua (not at all), so I don’t know if it can tap into the system clock, but since Wire can, I think lua can. This would be an excellent addition to this forum, and a valuable tool, so please make one!

I know that someone had tools for autosaving, but they have been blammed from

You could either just update your system completely, or tell it not to automatically restart. Your concept is possible, but it’s like asking for someone to build you a robot to pick up your daily newspaper in your front yard, when you could just get off your ass and pick it up yourself.


Fucking hell.

Control Panel > Windows Update > Change Settings (On the left) > Download updates but let me choose whether to install them > OK. Done.

My Windows is screwed up, as when a fullscreen game (gmod especially) is running, it gives no prompt at all, just installs them automatically. Windows and gmod are not torrents, and I don’t know why this happens, so I need something like a lua file to autosave it.

You’re going about this assbackwards.

Don’t write a Lua script to save your server from Windows Updates; fix your Windows Update settings to save your Garry’s Mod server.

I tried every single thread & solution to solve the Windows Update problem, they all said the same thing, including you guys. Yhat didn’t work, and it’s only with gmod, so I don’t really know what to do, except a lua script, which might work.

btw Foszor, I think gmod is the only place to weld something to an explosive barrel.

I got the solution, try this

And after set “Startup type” : (Disabled)
“Service Status” : Stop

Then After press Apply and OK.